If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Exception... "Cannot find interface information for parameter arg 0 [nsIDOMWindowInternal.pkcs11

VERIFIED FIXED

Status

()

Core
DOM
--
major
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: bc, Assigned: Benjamin Smedberg)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking1.9.1 -
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
ecma/ExecutionContexts/10.2.2-1.js

Exception... "Cannot find interface information for parameter arg 0 [nsIDOMWindowInternal.pkcs11]"  nsresult: "0x80570006 (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)"  location: "JS frame :: http://test.mozilla.com//tests/mozilla.org/js/ecma/ExecutionContexts/10.2.2-1.js :: <TOP_LEVEL> :: line 91"  data: no];

and similarly for:

ecma/ExecutionContexts/10.2.2-2.js
ecma_2/Statements/forin-002.js
js1_5/Array/regress-108440.js
js1_6/extensions/regress-455464-01.js
js1_6/extensions/regress-455464-02.js
js1_6/extensions/regress-455464-03.js
js1_6/extensions/regress-455464-04.js
js1_6/extensions/regress-475144.js
js1_7/extensions/regress-455982-01.js
js1_7/extensions/regress-455982-02.js
js1_8/extensions/regress-452476.js
js1_8/extensions/regress-476427.js
js1_8_1/trace/trace-test.js

all show this error in the browser. occurs in mozilla-central and tracemonkey.

regressed by bug 326628, http://hg.mozilla.org/mozilla-central/rev/eea9639048b8
sensitive since bug 326628 is.
Flags: in-testsuite+
Flags: blocking1.9.1?
(Assignee)

Comment 1

9 years ago
This doesn't need to be private. The problem seems to be that because nsIDOMpkcs11 is only a forward-declared interface and never exists, that we can't return it from a method, even though we only ever return "null".

We could either re-add nsIDOMpkcs11 and not implement it anywhere (which seems silly, but it will at least fix the bug, as well as bug 487960), or we could have xpconnect not look for interface info until after it got an object to wrap. The first definitely seems easier, but I'm open to suggestions.
Group: core-security
(Assignee)

Comment 2

9 years ago
Created attachment 372392 [details] [diff] [review]
Remove leftover references to nsIDOMPkcs11, rev. 1

On trunk we can just remove the extra references.

On the branch, I just left nsIDOMPkcs11.idl in the tree even though there are no implementers.
Attachment #372392 - Flags: review?(jst)
(Assignee)

Comment 3

9 years ago
This is only present on trunk, not a branch blocker.
Assignee: kaie → benjamin
Component: Security: PSM → DOM: Mozilla Extensions
Flags: blocking1.9.1? → blocking1.9.1-
QA Contact: psm → general
(Reporter)

Comment 4

9 years ago
This is present on tracemonkey. I need it fixed there as well.

Updated

9 years ago
Attachment #372392 - Flags: review?(jst) → review+

Updated

9 years ago
Attachment #372392 - Flags: superreview+
(Assignee)

Comment 5

9 years ago
http://hg.mozilla.org/mozilla-central/rev/c41b9f3a9d83
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
v 1.9.2. thanks.
Status: RESOLVED → VERIFIED

Comment 7

8 years ago
This patch seems to create a problem.

The "Load PKCS#11 Device" dialog (Minefield Preferences->Advanced->Encryption->Security Devices->Load) stops working.

The appropriate code is in mozilla-central\security\manager\pki\resources\content\device_manager.js:

function doLoadDevice()
{
  var name_box = document.getElementById("device_name");
  var path_box = document.getElementById("device_path");
  pkcs11.addmodule(name_box.value, path_box.value, 0,0);
  return true;
}

As pkcs11 reference has been removed, this dialog no longer works and produces the following error message: JavaScript error: chrome://pippki/content/device_manager.js, line 463: pkcs11 is not defined
(Assignee)

Comment 8

8 years ago
Gregory, that's a different bug (and was caused by bug 326628, not this one). Please file it separately and cc me.
(Assignee)

Comment 9

8 years ago
Backed this out with bug 326628... I'll just leave this bug closed and make sure to re-land it if appropriate when bug 326628 relands.
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.