If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SMTP send mail still fails for IMAP mail account

VERIFIED WORKSFORME

Status

MailNews Core
Networking: SMTP
P3
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: Martin Felker, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This bug was reported as fixed.    It is NOT.   When trying to send mail (not
receive mail which is OK) to an IMAP mail account (in this case cs.com) using
SMTP the server reports:

An error occurred while sending mail:   Client authentication required.  Use
ESMTP EHLO AND AUTH.  Please verfify that your email address address is correct
in your mail preferences and try again.

THIS ERROR DOES NOT OCCUR IN NETSCAPE 4.74 and previous.     It does occur (of
course) in NS 6 PR2.

Unless this is fixed Mail/News is unusable.

Please  reply ASAP

Marty Felker

Comment 1

17 years ago
I have the same problem, except there is no authentication.  It simply reports
an error when trying to send the mail, stating that the mail could not be sent. 
There's nothing specifics on the error message.
(Assignee)

Comment 2

17 years ago
Are you sure you set up your smtp server to require user name and password? edit 
your mailnews account settings and click on the smtp server and verify that the 
settings are correct.

can you please state the build number you are using as well? thanks.

Comment 3

17 years ago
Hmm, perhaps my problem is slightly different.  I'm not actually using any
authentication options as my smtp server doesn't require any.  My smtp server
settings simply point to my smtp mail host.  When I try to send a message, an
alert saying "Sending of message failed" appears and nothing else.  Should this
be a different bug or are they related?

I'm using build 2000081309.

Cheers,

Neil.

Comment 4

17 years ago
I have a similar problem. I am able to send mail when I have just logged into my
mail server. But when I attempt to send mail after the process has been running
for an extended period, I get an error, something along the lines of "Polite
users say HALO first." Apologies for not giving the exact message, but I have
just started up Mozilla and am not yet getting the error.

This makes using mozilla mail rather inconvenient.

Comment 5

17 years ago
smishra@everest.com - can you attach an smtp protocol log?
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html

(your problem may be the same symptom, but different cause since you were able
to send messages and only can't send after an extended time period.)

Comment 6

17 years ago
I downloaded a couple of days ago the latest nightly build, and this problem
appears to be solved. If it ever comes up again I will certainly report it.

Comment 7

17 years ago
Martin Felker, are you still seeing this problem in current builds?

Comment 8

17 years ago
Martin Felker, have you had a chance to test this again with a current build?
Without further comment this bug will be marked Worksforme.

Comment 9

17 years ago
Marking this as worksforme due to lack of comment from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

16 years ago
Closing an old bug. No longer re-producible.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.