dialog for "clear private data" option is called Settings for Clearing History

RESOLVED DUPLICATE of bug 464204

Status

()

RESOLVED DUPLICATE of bug 464204
10 years ago
10 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
The settings for clearing private data are in a dialog called Settings for Clearing History, which seems like a suboptimal name, given that they include options for clearing data in addition to history, and you access them by pressing a Settings button in a Preferences > Privacy > Private Data section next to the checkbox "Always clear my private data when I close Shiretoko".

In other words, everything leading up to that dialog talks about "data".  It isn't until you open that dialog that you see anything about history.  And even then, history isn't the only thing you see in it.

The dialog's name should be consistent with the context in which you open it, i.e. it should be called something like "Settings for Clearing Private Data".
There are lot of changes to our terminology for history and data coming in the next release, but not all of them have landed yet.  More details in bug 464204

In this case, the phrase "clear private data" should never appear, anything that is implicitly collected is being called history, and the set of things that the "clear recent history" dialog clears are only things that are implicitly collected.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 464204
You need to log in before you can comment on or make changes to this bug.