Unresponsive script dialog during file save

RESOLVED DUPLICATE of bug 476541

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 476541
9 years ago
9 years ago

People

(Reporter: dmi, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b4pre) Gecko/20090411 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9.1b4pre) Gecko/20090411 SeaMonkey/2.0b1pre

Warning: Unresponsive script

Script: chrome://navigator/content/tabbrowser.xml:467



Reproducible: Sometimes

Steps to Reproduce:
1. save image as
2. change filename

Actual Results:  
Clicks on Unresponsive script dialog buttons beep
Clicks on File Save dialog buttons change color briefly
no other response.
cpu time accumulating, force quit seems to be the only recourse



have a process sample from Activity Monitor, but it is long
Version: unspecified → Trunk

Comment 1

9 years ago
I had this problem in Firefox on Intel Mac (10.5.7) while trying to print to pdf.

Steps to reproduce:
1. While in a page running a script, print/save as pdf
2. Unresponsive script warning dialog comes up, attached to the browser window that is now in the background.

Results:
I can't click continue or stop script on the warning message, because the print/save dialog box is active.  But the print/save dialog boxes don't work - clicking Save or Cancel just flashes the buttons.  It's a dialog box deadlock, and the only way out is a force quit.  I also see an unlabeled window in the window menu (just a blank line).

Unfortunately Firefox auto-updated itself after force quit, at which point I was at:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
When the problem occurred I was at normal release 3.5.1.
That's a core issue on OS X and is already tracked in bug 476541. We should take care of this particular problem there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
You need to log in before you can comment on or make changes to this bug.