Closed Bug 488283 Opened 11 years ago Closed 9 years ago

Adware.Navipromo.AO rootkit causes Firefox to hang and stop loading pages

Categories

(Firefox :: General, defect)

All
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: cww, Unassigned)

Details

(Keywords: common-issue+)

Extremely common on Mozilla Italian forums, there's a virus going around that is installing with various software packages and causing Firefox to hang or stop loading pages.  Closing Firefox does not kill the process and users get a "Firefox is already running but not responding" message when they try to start again.  This only affects Firefox, Chrome is unaffected as is Explorer.

After extensive and detailed detective work: http://www.bitdefender.com/VIRUS-1000183-en--Adware.Navipromo.AO.html has been identified as the cause.

More information:
https://support.mozilla.com/tiki-view_forum_thread.php?comments_parentId=322151&forumId=3
The support link appears dead.  In any case, I don't see how Mozilla can take any action on this bug; shockingly, malware causes various types of bad behavior.  Marking as "RESOLVED INVALID".

If the malware installed some kind of Firefox extension, Firefox could try to blocklist it, but that obviously doesn't stop anything actively malicious.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.