[RFE] Preload mozilla invisible for faster startup times

VERIFIED DUPLICATE of bug 36283

Status

()

Core
XPCOM
P3
enhancement
VERIFIED DUPLICATE of bug 36283
17 years ago
17 years ago

People

(Reporter: Sebastian Späth, Assigned: Ray Whitmer)

Tracking

({verifyme})

Trunk
Future
x86
Windows 98
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Couldn't find that RFE yet in bugzilla so here it goes:

Slow startup time compared to IE has been mentioned alot. How difficult would it
actually be to have a kind of MozPreload.exe for Windows that loads the
necessary dll's without showing any browser windows to be put in "autostart".
While being no real improvement in terms of start up time, it would definitely
improve the /perceived/ startup time and boost up mozillas image in public.
Some people actually have the necessary RAM to leave a windowless Mozilla in
background running.

P.S. Sorry I hate browser-general, but this really *is* browser-general, isn't
it? :)

Comment 1

17 years ago
this is a dupe it was done before, I think it was marked invalid/won't fix...

Comment 2

17 years ago
If this is a dupe, I couldn't find it. I do remember sugesting this in a comment
I made to bug 29249. Since this is related to 29249 it probelly belongs in XPCOM
too.
This could be an option during install. "Do you want Mozilla to preload some
files during system startup?". Also an option in prefs.
This can do more than speed up Mozilla's launch. NC 4.74 can add a mail icon to
the system tray in Windows. It appears when you have new mail. Preloading files
could add an improved version of this ability to Mozilla. NC 4.x only does this
when it's launched. With preloaded files Mozilla could see if you you have new
mail at system launch.
This would make a good OPTION. There are far too many Win Aps that preload files
through the startup folder or the Win Reg. without bothering to ask if you want
this done. Mozilla dosen't need to join this group of rude aps.

Comment 3

17 years ago
over to XPCOM
Assignee: asa → rayw
Component: Browser-General → XPCOM
QA Contact: doronr → leger
(Assignee)

Comment 4

17 years ago
Making future.  It still isn't clear that XPCOM would be where this work would 
be done.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 5

17 years ago
Adding verifyme keyword.
Keywords: verifyme
QA Contact: leger → rayw

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 36283 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
veriyfing
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.