Status

NSPR
NSPR
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: N. Mckee, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.17) Gecko/20081018 BonEcho/2.0.0.17
Build Identifier: 4.7.3 

I was recently attempting to do an update to this in my Linux distro when an error message arose letting me know that there was a file collusion between it and Nvu (4.7.3).

I was asked to submit a bug report to you (I could not find a way of contacting Nvu's devs to do the same nor to just submit a bug report) in hopes of this possibly getting resolved, as I'm sure there are others out there who rely upon Mozilla software as well as who use Nvu.

The specific message I am getting is this one (generated by my distro when updating):

* QA Notice: Package has poor programming practices which may compile
* fine but exhibit random runtime failures.
* ../../../../mozilla/nsprpub/pr/src/io/prfdcach.c:165: warning: dereferencing type-punned pointer will break strict-aliasing rules
* ../../../../mozilla/nsprpub/pr/src/io/prfdcach.c:224: warning: dereferencing type-punned pointer will break strict-aliasing rules
* ../../../../mozilla/nsprpub/pr/src/misc/prthinfo.c:109: warning: dereferencing type-punned pointer will break strict-aliasing rules
* ../../../../mozilla/nsprpub/pr/src/misc/prthinfo.c:235: warning: dereferencing type-punned pointer will break strict-aliasing rules
* ../../../../mozilla/nsprpub/pr/src/pthreads/ptio.c:903: warning: dereferencing type-punned pointer will break strict-aliasing rules

* Please do not file a Gentoo bug and instead report the above QA
* issues directly to the upstream developers of this software.
* Homepage: http://www.mozilla.org/projects/nspr/

>>> Installing dev-libs/nspr-4.7.3

* Messages for package dev-libs/nspr-4.7.3:

* This package will overwrite one or more files that may belong to other
* packages (see list below). You can use a command such as `portageq
* owners / <filename>` to identify the installed package that owns a
* file. If portageq reports that only one package owns a file then do
* NOT file a bug report. A bug report is only useful if it identifies at
* least two or more packages that are known to install the same file(s).
* If a collision occurs and you can not explain where the file came from
* then you should simply ignore the collision since there is not enough
* information to determine if a real problem exists. Please do NOT file
* a bug report at http://bugs.gentoo.org unless you report exactly which
* two packages install the same file(s). Once again, please do NOT file
* a bug report unless you have completely understood the above message.
*
* Detected file collision(s):
*
* /usr/share/aclocal/nspr.m4
*
* Searching all installed packages for file collisions...
*
* Press Ctrl-C to Stop
*
* app-editors/nvu-1.0-r4
* /usr/share/aclocal/nspr.m4
*
* Package 'dev-libs/nspr-4.7.3' NOT merged due to file collisions. If
* necessary, refer to your elog messages for the whole content of the
* above message.

If any additional information is required, please let me know. Thanks!

Reproducible: Always

Steps to Reproduce:
1.Attempt to update Nspr to 4.7.3 on a Linux system that has Nvu installed as well (which also will produce an error message when attempting to just update it regarding the file collusion problem).
Actual Results:  
Error message gets generated and no updates to either nspr (or any program that may depend upon it) or Nvu occur (at least, in Gentoo Linux--it may be the same in other distros) to prevent any files from being overwritten and creating problems for the other or anything which may rely upon them.

Expected Results:  
It should have just been able to update (without the risk of anything being overwritten).

While this happened in Gentoo, given the file collusion, it may likely also affect other Linux distros as well. I, obviously, can't update any of the packages that depend upon Nspr (nor nspr, itself) until this gets resolved somehow or without having to remove/uninstall Nvu.
(Assignee)

Comment 1

9 years ago
Thanks for the bug report.  I'm afraid that you need to file
a bug report in Gentoo's bug tracking system, against the
app-editors/nvu-1.0-r4 Gentoo package.  The app-editors/nvu-1.0-r4
package should not need to install /usr/share/aclocal/nspr.m4,
or it should depend on the dev-libs/nspr-4.7.3 package and get
/usr/share/aclocal/nspr.m4 from dev-libs/nspr-4.7.3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Assignee)

Comment 2

9 years ago
I just installed both nspr and nvu on Ubuntu 8.04 LTS.  The
equivalent packages are called kompozer-dev and libnspr4-dev
in Ubuntu.  (The nvu-dev package is provided as a "transition"
package for kompozer-dev.)

I confirmed that both packages installed /usr/share/aclocal/nspr.m4.

$ apt-file search /usr/share/aclocal/nspr.m4
kompozer-dev: /usr/share/aclocal/nspr.m4
libnspr4-dev: /usr/share/aclocal/nspr.m4

Looking at the installation log closer, I found that
the conflict was avoided by kompozer-dev's removing
the libnspr4-dev package!

$ sudo apt-get install nvu-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  kompozer-dev
The following packages will be REMOVED:
  libnspr4-dev libnss3-dev
The following NEW packages will be installed:
  kompozer-dev nvu-dev
0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 2597kB of archives.
After this operation, 18.4MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://apt-goobuntu hardy/universe kompozer-dev 1:0.7.10-0ubuntu4 [2576kB]
Get:2 http://apt-goobuntu hardy/universe nvu-dev 1:0.7.10-0ubuntu4 [20.7kB]
Fetched 2597kB in 1s (1543kB/s)
(Reading database ... 304457 files and directories currently installed.)
Removing libnss3-dev ...
Removing libnspr4-dev ...
Selecting previously deselected package kompozer-dev.
(Reading database ... 304257 files and directories currently installed.)
Unpacking kompozer-dev (from .../kompozer-dev_1%3a0.7.10-0ubuntu4_all.deb) ...
Selecting previously deselected package nvu-dev.
Unpacking nvu-dev (from .../nvu-dev_1%3a0.7.10-0ubuntu4_all.deb) ...
Setting up kompozer-dev (1:0.7.10-0ubuntu4) ...
Setting up nvu-dev (1:0.7.10-0ubuntu4) ...

When I tried to reinstall libnspr4-dev, I got a conflict:

$ sudo apt-get install libnspr4-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  nvu-dev
The following NEW packages will be installed:
  libnspr4-dev
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 271kB of archives.
After this operation, 1462kB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://apt-goobuntu hardy-updates/main libnspr4-dev 4.7.1+1.9-0ubuntu0.8.04.5 [271kB]
Fetched 271kB in 0s (3458kB/s)
(Reading database ... 306913 files and directories currently installed.)
Removing nvu-dev ...
Selecting previously deselected package libnspr4-dev.
(Reading database ... 306912 files and directories currently installed.)
Unpacking libnspr4-dev (from .../libnspr4-dev_4.7.1+1.9-0ubuntu0.8.04.5_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libnspr4-dev_4.7.1+1.9-0ubuntu0.8.04.5_amd64.deb (--unpack):
 trying to overwrite `/usr/share/aclocal/nspr.m4', which is also in package kompozer-dev
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libnspr4-dev_4.7.1+1.9-0ubuntu0.8.04.5_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So there is definitely a conflict between kompozer-dev and
libnspr4-dev, but this is out of the control of us the
upstream NSPR maintainers.
(Assignee)

Comment 3

9 years ago
I can help you report this issue to the Nvu or Kompozer developers.
Let me know...  I just did a quick web search and found the Kompozer
bug report page here:
http://sourceforge.net/tracker/?group_id=170132&atid=853122
You need to log in before you can comment on or make changes to this bug.