Polish: "Save as" dialog combo box not wide enough on nl_NL locale

UNCONFIRMED
Unassigned

Status

()

--
trivial
UNCONFIRMED
10 years ago
7 years ago

People

(Reporter: znerd, Unassigned)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.0.9) Gecko/2009040820 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.0.9) Gecko/2009040820 Firefox/3.0.9

The "Save as" dialog dor a web page shows a combo box with several options for the format to save the file in.

Although this combo box ma be wide enough on some locales, it's not wide enough on the nl_NL locale, although the dialog window itself has more than enough available space.

I propose rendering the combo box as follows:
- keep the current X-position
- make the width dependent of the contents, maximized by the dialog width

I have not testeed this issue on other platforms, only on Mac OS X (10.5 Leopard) with the nl_NL locale.

I do not expect this to be a regression.

Reproducible: Always

Steps to Reproduce:
1. Use Mac OS X 10.5.6, with Mozilla Firefox 3.0.9 beta (build 2)
2. Go to any web page
3. Press Cmd-S
Actual Results:  
See attached screenshot

Expected Results:  
No ellipsis shown, just the complete text of the option.
(Reporter)

Comment 1

10 years ago
Created attachment 373063 [details]
Screenshot showing the dialog with the combo box
(Reporter)

Comment 2

10 years ago
Created attachment 373064 [details]
Screenshot of the contents of the dialog box
(Reporter)

Updated

10 years ago
Keywords: polish

Updated

10 years ago
Assignee: nobody → dutch.nl
Component: General → nl / Dutch
Product: Firefox → Mozilla Localizations
QA Contact: general → dutch.nl
I think this is something in the mac(theme), firefox doesn't render this window, it's provide only the text in the pull down menu.

So I don't think this can be fixed on the locale level, Pike can you confirm this?

Comment 4

10 years ago
I think that that's a native mac dialog, not sure how much power we could have over it. Josh, Faaborg?

Comment 5

10 years ago
We do have some power over it, we provide the native control for the saving options view.
marking as wontfix, because we can't fix it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX

Comment 7

10 years ago
We can fix it.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 8

10 years ago
Josh, I'm moving this into Widget: Mac for the lack of a better idea on how to get the platform-specific nature of this into the component.

We should get this out of l10n, though, as the dutch localization can't fix it without some back end work.
Assignee: dutch.nl → nobody
Component: nl / Dutch → Widget: Mac
Product: Mozilla Localizations → Core
QA Contact: dutch.nl → mac

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard

Updated

8 years ago
Blocks: 666042

Updated

8 years ago
No longer blocks: 666042
Is this still a issue or can we close this bug?
(Reporter)

Comment 10

7 years ago
Still an issue on Firefox 10. I'll attach another screenshot.
(Reporter)

Comment 11

7 years ago
Created attachment 593565 [details]
Screenshot of the dialog box on Firefox 10

Comment 12

7 years ago
Moving this out of the graveyard per comment #10
Component: Widget: Mac → Widget: Cocoa
Product: Core Graveyard → Core
QA Contact: mac → cocoa
You need to log in before you can comment on or make changes to this bug.