can get text area to cause infinite loop on MacOS

VERIFIED FIXED

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: saari (gone), Assigned: mjudge)

Tracking

({crash})

Trunk
PowerPC
Mac System 8.5
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm need info] fixed by NOXIF landing, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
1) bring up bug in http://bugzilla.mozilla.org/show_bug.cgi?id=29800
2) copy the following into the Additional Comments field

Index: nsPresShell.cpp
===================================================================
RCS file: /m/pub/mozilla/layout/html/base/src/nsPresShell.cpp,v
retrieving revision 3.325
diff -w -u -2 -r3.325 nsPresShell.cpp
--- nsPresShell.cpp	2000/08/10 22:07:33	3.325
+++ nsPresShell.cpp	2000/08/14 01:53:05
@@ -3897,5 +3897,5 @@
           // works.  However, this point is relative to the frame's rect, so
           // we need to add on the origin of the rect.
-          nsPoint eventPoint;
+/*          nsPoint eventPoint;
           frame->GetOrigin(eventPoint);
           eventPoint += aEvent->point;
@@ -3907,4 +3907,5 @@
               if (rv != NS_OK) {
 #ifdef XP_MAC
+*/
                 // On the Mac it is possible to be running with no windows open, 
only the native menu bar.
                 // In this situation, we need to handle key board events but 
there are no frames, so
@@ -3912,5 +3913,5 @@
                 mCurrentEventContent = mDocument->GetRootContent();
                 mCurrentEventFrame = nsnull;
-#else
+/*#else
 								if (aForceHandle) {
 									mCurrentEventFrame = frame;
@@ -3925,4 +3926,5 @@
             }
           }
+*/
         }
       }


3) click the Accept bug radio button. That shoul put you into an infinite loop 
and take down MacOS.
(Reporter)

Comment 1

18 years ago
Reassigning to beppe as this looks ender specific
Assignee: rods → beppe

Comment 2

18 years ago
assigning to mjudge and cc sfraser since he is Mr. Mac
Assignee: beppe → mjudge

Comment 3

18 years ago
simon/mike What do you think we should do here?
Whiteboard: [need info]

Comment 4

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Comment 5

18 years ago
can we get a mac person to re-test this to evaluate for m19 or future?

anthonyd

Comment 6

18 years ago
asked brade if she would look at this today

Comment 7

17 years ago
I looked at this last week; I could only reproduce the infinite loop once (but 
maybe I was seeing something else?)

I'll try to look at it again soon.

Comment 8

17 years ago
moving this out to future
Target Milestone: --- → Future

Comment 9

17 years ago
renominate for rtm; remove Future milestone
I was able to reproduce this today; I have a macsbug log which I'll attach.
add crash keyword (though it's an infinite loop)
Keywords: crash, rtm
Target Milestone: Future → ---

Comment 10

17 years ago
Created attachment 16252 [details]
macsbug log of stack crawl

Comment 11

17 years ago
updated status
Whiteboard: [need info] → [rtm need info]

Comment 12

17 years ago
brade: didn't we debug this once, and find that some nsString& was being set to 
null?

This may go away when NOXIF lands.

Comment 13

17 years ago
Marking dependent on the NOXIF bug.
Depends on: 50742

Comment 14

17 years ago
i'm confused.  is the infinite loop a loop of asserts?  The stack trace shows you 
are in an assert...

Comment 15

17 years ago
Yes the stack crawl above is not from a crash; there are about 15 asserts or so 
that get hit.  I have seen a crash doing the above steps but I can't reliably 
reproduce it.

The one time I crashed in the debugger, I didn't have all of the symbols loaded 
so Simon and I were seeing bad data values from the debugger so I'm not sure what 
is going on yet.  Sorry!

Comment 16

17 years ago
I can't reproduce this bug at all with a mac debug build from today.  I don't
even see the asserts.  I think the NOXIF landing fixed this so I'm going to
resolve as fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: [rtm need info] → [rtm need info] fixed by NOXIF landing
Target Milestone: --- → M19

Comment 17

17 years ago
Verified build2001070908 os/mac8.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.