New version of JEP (0.9.7), please land on branches

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: smichaud, Assigned: smichaud)

Tracking

({verified1.9.1})

Bug Flags:
blocking1.9.1 +
wanted1.9.0.x -

Details

Attachments

(1 attachment)

JEP 0.9.7 is a major update to the Java Embedding Plugin.

It fixes or alleviates several quite visible bugs, and adds
compatibility with current seeds of Mac OS X 10.6 (SnowLeopard).  It
also adds MIME-type information to the MRJ Plugin JEP's Info.plist,
allowing Firefox to drop support for resource files once the Flash
plugin also does this (see bug 468678).

Along with OJI support, the Java Embedding Plugin has now been removed
from the trunk (see bug 485984).  So we can't land the new JEP there.

But I'd like to land JEP 0.9.7 on the 1.9.1 branch as soon as possible
-- with the aim of getting it into Firefox 3.5 beta4.

I'd also like to land it on the 1.9.0 branch and even the 1.8 branch
(for current Seamonkey releases) ... though this is less urgent.

http://javaplugin.sourceforge.net/

Those who want to try the new version right away will need to install
it "over" the older versions currently bundled with Mozilla.org
browsers.  I recommend installing the new JEP to your
/Library/Internet Plug-Ins/ folder, then removing older copy(ies) of
the JEP from your Mozilla.org browser(s).  For more information see
the JEP Readme (http://javaplugin.sourceforge.net/Readme.html).
Attachment #373188 - Flags: review?(joshmoz)
We can pick this up in 1.9.0.11.
Flags: wanted1.9.0.x+
Flags: wanted1.8.1.x+
Flags: blocking1.9.1?
(Following up comment #0)

> and even the 1.8 branch (for current Seamonkey releases)

Oops, this probably won't work:  JEP 0.9.7 only supports OS X 10.4.11
and above, but Seamonkey 1.X still officially supports OS X 10.2 and
above.
Oh, good point. We won't take this on the 1.8 branch.
Flags: wanted1.8.1.x+
If you want it in b4, it needs to be reviewed and baked on trunk in the next few hours. Why did we leave this so late if it was so urgent?
> Why did we leave this so late if it was so urgent?

I've been working like a dog for the last month, seven days a week, to
get this done.  It just took longer than I thought.
> baked on trunk

It can't be landed on the trunk, which no longer has OJI.  See comment #0.
>> Why did we leave this so late if it was so urgent?
>
> I've been working like a dog for the last month, seven days a week,
> to get this done.  It just took longer than I thought.

I guess I also expected the ususal "slushy freeze" :-)

Comment 9

10 years ago
(In reply to comment #3)
> JEP 0.9.7 only supports OS X 10.4.11 and above

That means that landing this on 1.9.0 changes the system requirements for Firefox 3.0 in a minor update (and forces an OS requirement change on our Camino 2 release as well).

I guess don't have a problem with the requirement from the Camino side, but changing the OS requirement in a minor release of a stable Gecko branch seems like something that should be discussed more than it seems like it has been here (although perhaps there was discussion elsewhere that I'm not aware of).
(In reply to comment #9)

> That means that landing this on 1.9.0 changes the system
> requirements for Firefox 3.0 in a minor update

Nope.  Firefox 3.0.X only supports OS X Tiger and up.

> (and forces an OS requirement change on our Camino 2 release as
> well)

I was unaware of this.

But system requirements are a real issue on the 1.8 branch.

Comment 11

10 years ago
(In reply to comment #10)
> > That means that landing this on 1.9.0 changes the system
> > requirements for Firefox 3.0 in a minor update
> 
> Nope.  Firefox 3.0.X only supports OS X Tiger and up.

Tiger is 10.4.0+, not 10.4.11+. I'm not saying it's an enormous change, but there *are* users who are running 10.4.x where x < 11 (some out of laziness, some explicitly)

Changing this means changing any web pages that refer to system requirements, making extremely sure that Firefox 3.0.x+1 will not be delivered via auto-update to users who can't run it, and accepting that some (relatively small, but non-zero) users will be frozen at the last 3.0.x release before the new JEP, and thus be missing security updates.

I'm not saying it's not doable, but it is a requirements change that will affect users, and as such should be explicitly made as a policy choice with full understanding of the implications.
(In reply to comment #11)
> Tiger is 10.4.0+, not 10.4.11+. I'm not saying it's an enormous change, but
> there *are* users who are running 10.4.x where x < 11 (some out of laziness,
> some explicitly)

And really, I don't think Firefox 3.5 supports specifically 10.4.11+ right now, so we'd need to enforce that somehow at the app-level if we're going to change the requirements. (So users know why something might be broken.)
I didn't realize what you were saying.

And I was also being a little vague:  JEP 0.9.7 supports OS X 10.4.X
and above, not just OS X 10.4.11.

I'll change this in my online docs.

Comment 14

10 years ago
(In reply to comment #13)
> And I was also being a little vague:  JEP 0.9.7 supports OS X 10.4.X
> and above, not just OS X 10.4.11.

Just to be very clear, does that mean "has been tested back to 10.4.0"? My vague understanding (perhaps incorrect) is that JEP does have some reliance on undocumented internals, in which case minor version compatibility can't be taken for granted.
None of the things the undocumented stuff the JEP relies on changes
except between major versions (I know this from long experience).

Also, previous versions of the JEP were tested on new minor releases of
OS X Tiger as they came out, and I've made no changes since then that
would have broken compatibility on point releases of OS X 10.4 before
10.4.11.

So no, I haven't tested JEP 0.9.7 on point releases of OS X 10.4 prior
to 10.4.11.  (Nor did I test any of the previous JEP releases that
have come out since OS X 10.4.11 was released.)  But I'm quite
confident that JEP 0.9.7 will work on point releases of Tiger prior to
10.4.11.
(In reply to comment #12)
> And really, I don't think Firefox 3.5 supports specifically 10.4.11+ right now,
> so we'd need to enforce that somehow at the app-level if we're going to change
> the requirements. (So users know why something might be broken.)

FYI, the "correct" way to do that is set LSMinimumSystemVersion in your plist—though I'm not sure if it works "correctly" (shows a message saying your Mac does not meet the requirements of the software, rather than simply preventing launch silently) on 10.4.  "If" since the code that deals with that key has a history of being buggy (it showed no message at all on 10.3-anything, just silently prevented launch).

From a quick trip to Google, it looks like LSMinimumSystemVersion is broken-by-showing-no-message-silently-preventing-launch on 10.4.0, and broken-by-showing-the-message-even-if-you-have-the-minimum-version on 10.4.1-10.4.11.

So to meet the requirement of "(So users know why something might be broken.)" you'd have to write a custom launch+notification mechanism.
Josh: please expedite review of this P1 blocker?
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
(In reply to comment #16)

For what it's worth, I make MRJPlugin.plugin's NSGetFactory() (an
entrypoint called from the browser) fail with NS_ERROR_FAILURE if
Gestalt shows an OS X version less than 0x1040 (i.e. less than OS X
10.4).

Comment 19

10 years ago
I'm starting to test/review right now. I'll be done within a couple of hours.

Comment 20

10 years ago
Comment on attachment 373188 [details]
Change log for JEP 0.9.7

Looks good to me, tested with Firefox 3.0.8 and 3.5 nightly.
Attachment #373188 - Flags: review?(joshmoz) → review+
smichaud: please land on 191 when there's a green tree
Whiteboard: [needs 1.9.1 landing]
Landed on the 1.9.1 branch:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/9b52390838f0
Keywords: fixed1.9.1
Whiteboard: [needs 1.9.1 landing]
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Putting this on our radar for 1.9.0.11. There's no approval flag yet, but when we're ready for approvals, I'll ping in this bug.
Flags: blocking1.9.0.11?
Verified fixed on the 1.9.1 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090423 Shiretoko/3.5b4pre.
Flags: blocking1.9.0.12? → blocking1.9.0.12+
(Assignee)

Updated

10 years ago
Attachment #373188 - Flags: approval1.9.0.12?
Flags: blocking1.9.0.12+
Comment on attachment 373188 [details]
Change log for JEP 0.9.7

Minusing in favor of the newer one.
Attachment #373188 - Flags: approval1.9.0.12? → approval1.9.0.12-
Flags: wanted1.9.0.x+ → wanted1.9.0.x-

Updated

9 years ago
Component: Java Embedding Plugin → Java (Java Embedding Plugin)
Product: Core → Plugins
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.