[REGRESSION] IcedTeaPlugin does not work at all in seamonkey 2.0b1pre

RESOLVED FIXED in Apr 2010

Status

Plugins Graveyard
Java (IcedTea)
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: Tomas Janousek, Unassigned)

Tracking

Apr 2010
x86
Linux

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9.1b4pre) Gecko/20090417 SeaMonkey/2.0b1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9.1b4pre) Gecko/20090417 SeaMonkey/2.0b1pre

In Seamonkey 2.0a3 and in Firefox 3.0.4, the IcedTeaPlugin (java plugin shipped with openjdk) works just fine. In Seamonkey 2.0b1pre-20090311 and 2.0b1pre-20090417 (and possibly others), it spits two errors very early and does not work at all:
../IcedTeaPlugin.cc:3708: Error: create process
../IcedTeaPlugin.cc:1661: Error: started appletviewer

I'm attaching error outputs with ICEDTEAPLUGIN_DEBUG=1.

Though this may be an error on IcedTeaPlugin's side, I believe it is more of a problem in Seamonkey, since Sun Java plugin stopped working at about the same time (which led me to replacing Sun Java with openjdk, now it at least does not crash/hang :)).

Reproducible: Always

Steps to Reproduce:
1. visit http://java.sun.com/applets/jdk/1.4/demo/applets/Clock/example1.html
(Reporter)

Comment 1

9 years ago
Created attachment 373425 [details]
2.0a3 log
(Reporter)

Comment 2

9 years ago
Created attachment 373426 [details]
2.0b1pre-20090311 log
(Reporter)

Comment 3

9 years ago
Created attachment 373427 [details]
2.0b1pre-20090417 log

Comment 4

9 years ago
Fedora 10.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090418 NOT Firefox/2.0.0.20 SeaMonkey/2.0b1pre ID:20090418123653

Mine stops working too, with these errors on console:
[misak@misak bin]$ ./seamonkey
cz-service: No windows, starting new one.
IcedTeaPlugin.cc:3632: Error: create process
IcedTeaPlugin.cc:1659: Error: started appletviewer

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_write_chars: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3841: Error: Failed to write bytes to output channel

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_flush: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3855: Error: Failed to flush bytes to output channel

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_write_chars: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3841: Error: Failed to write bytes to output channel

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_flush: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3855: Error: Failed to flush bytes to output channel

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_write_chars: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3841: Error: Failed to write bytes to output channel

(seamonkey-bin:21516): GLib-CRITICAL **: g_io_channel_flush: assertion `channel != NULL' failed
IcedTeaPlugin.cc:3855: Error: Failed to flush bytes to output channel

It seems it starts behave this way from last IcedTea update, but i'm not sure.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Component: General → Plug-ins
Product: SeaMonkey → Core
QA Contact: general → plugins

Comment 5

9 years ago
this may sound like a stupid question, but i'll ask anyway:

why haven't you complained to icedtea?
(Reporter)

Comment 6

9 years ago
Because

> Though this may be an error on IcedTeaPlugin's side, I believe it is more of a
> problem in Seamonkey, since Sun Java plugin stopped working at about the same
> time (which led me to replacing Sun Java with openjdk, now it at least does not
> crash/hang :)).

I may file a report there as well if you think that's a good idea.

Comment 7

9 years ago
i do, i do.

Comment 9

9 years ago
fwiw, if i have the right thread, this is probably: http://groups.google.com/group/mozilla.dev.planning/browse_thread/thread/8741dfad2f92a59/9a22cfe8766716c0?lnk=gst&q=java+oji#9a22cfe8766716c0

which we announced (m.d.planning is our announce area), assuming it's the right break, this is intentional, and they'll have to fix it.
(Reporter)

Comment 10

9 years ago
Ok then.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Component: Plug-ins → Java (IcedTea)
Product: Core → Plugins
QA Contact: plugins → icedtea-java
As stated on the IcedTea bug; you need to upgrade to a newer version of IcedTea6 that includes NPPlugin (the rewrite for the XULRunner 1.9.2+ API).  This can be either 1.7.x (built with the --enable-npplugin option, which is enabled by default if XULRunner 1.9.2 or higher is detected) or 1.8 (which only has this new plugin, the old one having being dropped).

Updated

8 years ago
Resolution: WONTFIX → FIXED
Target Milestone: --- → Apr 2010
Version: unspecified → 1.x
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.