All users were logged out of Bugzilla on October 13th, 2018

&lang and &rang are not escaped

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
8 years ago

People

(Reporter: Noah, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090401 Firefox/3.0
Build Identifier: 

In the forums, posting [&lang] and [&rang] inside links produces a unicode character confusing users. Visit this thread to see testcase:
https://support.mozilla.com/tiki-view_forum_thread.php?forumId=3&comments_parentId=330915

Reproducible: Always

Comment 1

10 years ago
This is because &lang is a valid HTML entity for left angle bracket thus links with &lang=en-US show up as 〈=en-US because the & isn't escaped into &
Component: Forum → General
QA Contact: forum → general
Summary: Tikiwiki parsing &lang and &rang in links as HTML entities → &lang and &rang are not escaped

Comment 2

10 years ago
CCing people for attention.

Comment 3

10 years ago
Not sure if I understand what the problem is, or what kind of attention is needed?
Posting links with &lang query params in kitsune works just fine.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.