Open Bug 489067 Opened 13 years ago Updated 5 years ago

[SM] Allow inline background color for selected text in Message Compose

Categories

(SeaMonkey :: MailNews: Composition, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

REOPENED

People

(Reporter: tsahi_75, Unassigned)

References

Details

Currently (seamonkey 1.1) the message composition window only allows painting the entire message background. When a text is selected, it should be allowed to paint only the background of the selected text, just as it paints the foreground of selected text when foreground color is selected.

repro:
1. write some text in a new message.
2. select some text in the message
3. select a background color.

actual result: the entire message gets the selected color background.
expected: only the selected text should get the selected color background.
OS: Windows XP → All
Hardware: x86 → All
Can you reproduce with SeaMonkey v2.0a3?
Version: Other Branch → SeaMonkey 1.1 Branch
I don't have seamonkey anymore, but it's easy to check, i guess. it's still there in the latest thunderbird editor.
It appears this is basically the same as Bug 121210 - it is marked as MailNews Core, but I'm not sure this applies now that Thunderbird and SeaMonkey have different front-ends (or I'm wrong?).  The feature to highlight inline text is in the SeaMonkey Composer but not in the UI for the MailNews composition.
This is probably something in the shared editor/ui code, as you can also see it if you go into SeaMonkey Composer and use the formatting toolbar icons. I imagine it would be fairly easy to add a format text background color... menu item
Severity: normal → enhancement
Version: SeaMonkey 1.1 Branch → Trunk
This truly looks like a duplicate of Bug 121210 to me.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 121210
(In reply to Ian Neal from comment #4)
I'll see whether I could prepare a patch which doesn't mess with shared code.
Assignee: nobody → stanio
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Stanimir Stamenkov from comment #7)
> (In reply to Ian Neal from comment #4)
> I'll see whether I could prepare a patch which doesn't mess with shared code.

The XUL code itself is forked between TB and SM but the JS code that the XUL needs to use isn't.
http://mxr.mozilla.org/comm-central/search?string=EditorSelectColor&filter=[Ee]ditorSelectColor
IIRC this happens because the inline background color requires CSS which is disabled in the mail editor.
(If you turn off CSS in Composer preferences then the highlight tool disappears too.)
Yep.  I've found these already.  Currently I'm tracing why the composer preference doesn't affect the mail HTML compose and why the highlight button doesn't disappear from the mail compose window (once added to the XUL), if the Composer CSS preference is turned off - something related with getCurrentEditor(), etc.
Summary: Allow inline background color → Allow inline background color in Message Compose.
Summary: Allow inline background color in Message Compose. → Allow inline background color for selected text in Message Compose
See Also: → 318600
Stanimir (assignee), it would be very cool if are still willing to fix this (ideally so that fix applies to both TB and SM)...?

As it stands, I read Stanimir's comment 7 that he wants to fix this for SM only.
Flags: needinfo?(stanio)
Summary: Allow inline background color for selected text in Message Compose → [SM] Allow inline background color for selected text in Message Compose
Duplicate of this bug: 776911
(In reply to Thomas D. (away till 23rd Oct) from comment #12)
> Stanimir (assignee), it would be very cool if are still willing to fix this
> (ideally so that fix applies to both TB and SM)...?

Sorry for taking it that long.  I should have unassigned myself long time ago.  Unfortunately I don't know when I would get enough time to look into it again.
Assignee: stanio → nobody
Flags: needinfo?(stanio)
See Also: → 1062093
You need to log in before you can comment on or make changes to this bug.