Closed Bug 489077 Opened 11 years ago Closed 11 years ago

[SeaMonkey] mochitest-browser-chrome: running browser_async.js + browser_whitelist.js triggers a 1176 bytes leak

Categories

(SeaMonkey :: Download & File Handling, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 474152
seamonkey2.0b1

People

(Reporter: sgautherie, Unassigned)

Details

(Keywords: memory-leak, regression)

Bug 480752 comment 1:
{
From  Serge Gautherie (:sgautherie)   2009-02-28 15:03:34 PDT

PS:
This test suite reports a new leak (maybe related), but let's fix the failures
first...
}

The failures from that bug have been fixed, but a leak remains.
(Read there for a possible beginning timeframe...)


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090417 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/9e06217fc471
 +http://hg.mozilla.org/comm-central/rev/...)

Seen when running the whole suite, but these 2 tests are enough:
http://mxr.mozilla.org/mozilla-central/source/testing/mochitest/tests/browser/browser_async.js
http://mxr.mozilla.org/mozilla-central/source/xpinstall/tests/browser_whitelist.js

{
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1176 bytes during test execution
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsBinaryOutputStream with size 16 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsBufferedInputStream with size 48 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsBufferedOutputStream with size 56 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 2 instances of nsBufferedStream with size 40 bytes each (80 bytes total)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 2 instances of nsFastLoadFileUpdater with size 240 bytes each (480 bytes total)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 2 instances of nsFastLoadFileWriter with size 228 bytes each (456 bytes total)
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsStringBuffer with size 8 bytes
TEST-UNEXPECTED-FAIL | runtests-leaks | leaked 1 instance of nsSystemPrincipal with size 32 bytes
}

Can someone else reproduce?
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090518
SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/a7c0b3588242
 +http://hg.mozilla.org/comm-central/rev/6786ebf24275 + bug 493008 patches)

(Still there.)
Blocks: SmTestLeak
No longer blocks: mlkTests
Bug 464795 landing on m-1.9.1 is causing this !

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1243355723.1243360235.14402.gz
Linux comm-central unit test on 2009/05/26 09:35:23
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1243355724.1243361399.16759.gz
OS X 10.4 comm-central unit test on 2009/05/26 09:35:24
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1243355723.1243359868.13807.gz
WINNT 5.2 comm-central unit test on 2009/05/26 09:35:23

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Ports/1243355723.1243360646.15062.gz
Linux comm-1.9.1 unit test on 2009/05/26 09:35:23
[Probably same on MacOSX, though the box is just too broken atm.]
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Ports/1243355723.1243361503.17058.gz
WINNT 5.2 comm-1.9.1 unit test on 2009/05/26 09:35:23
Blocks: 464795
No longer blocks: CcMcBuildIssues
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.9.1?
Keywords: qawantedregression
OS: Windows 2000 → All
Whiteboard: [See comment 2]
(In reply to comment #2)
> Bug 464795 landing on m-1.9.1 is causing this !

What leads you to that conclusion? This bug was filed before that happened, and it's not obvious to me how these two would be related.
(In reply to comment #3)
> > Bug 464795 landing on m-1.9.1 is causing this !
> 
> What leads you to that conclusion?

c-c had no checkin; m-1.9.1 had this checkin only.

> This bug was filed before that happened, and

It doesn't look like so to me:
bug 464795 comment 11 checkin happened more than a month earlier.

> it's not obvious to me how these two would be related.

I have no idea: maybe it is only "triggering" the leak?
So are you saying you're able to reproduce this consistently? Why aren't the tinderboxes orange?
(In reply to comment #5)
> So are you saying you're able to reproduce this consistently?

Yes, this leak is 100% reproducible with my local SM/1.9.2 build(s).
(I haven't tried to back out bug 464795 though.)

> Why aren't the tinderboxes orange?

I don't what you are looking at, but the 2*3 SM/1.9.1 boxes are steadily orange.
(Even without this bug :-< But that's not the point.)
Summary: mochitest-browser-chrome: running browser_async.js + browser_whitelist.js triggers a 1176 bytes leak → [SeaMonkey] mochitest-browser-chrome: running browser_async.js + browser_whitelist.js triggers a 1176 bytes leak
Bug 474152 landing fixed the (1.9.1) boxes,

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090527 SeaMonkey/2.0b1pre] (experimental/_m-c_, home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/0dffee5de077
 +http://hg.mozilla.org/comm-central/rev/58cf9794dd27 + bug 493008 patches)

and I verified it fixed my local (1.9.2) build too :-)

I guess I tested without bug 474152 patch initially :-/
No longer blocks: SmTestLeak, 464795
Status: NEW → RESOLVED
Closed: 11 years ago
Component: General → Download & File Handling
Flags: blocking1.9.1?
QA Contact: general → download
Hardware: x86 → All
Resolution: --- → DUPLICATE
Whiteboard: [See comment 2]
Target Milestone: --- → seamonkey2.0b1
Duplicate of bug: 474152
You need to log in before you can comment on or make changes to this bug.