blank tab focus should automatically always go to URL bar

RESOLVED DUPLICATE of bug 565575

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 565575
10 years ago
8 years ago

People

(Reporter: kwiniec, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8

A blank tab apparently has 3 elements on which it can indefinitely maintain the focus, but only the URL bar is useful.  This adds inconventience when (1) a click occurs somewhere in a selected blank tab other than the URL bar; (2) a blank tab is created with addTab / loadOneTab / openNewTabWith, which unlike command-t (File menu New Tab item) and the New Tab toolbar button, put the focus on one of the other two elements; and (3) when the "about:blank" URL is loaded manually or from a bookmark.

Reproducible: Always

Updated

9 years ago
OS: Mac OS X → All

Updated

8 years ago
Blocks: 565575

Comment 1

8 years ago
Re: case (1): Clicking on UI elements besides the URL bar, i.e. the search bar, while a blank tab is selected can absolutely be useful, and it would completely violate ux-control not to focus those elements when clicked. Therefore, WONTFIX.

Cases (2) and (3) are covered by bug 565575.
No longer blocks: 565575
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 565575
You need to log in before you can comment on or make changes to this bug.