If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Should be able to transfer items across trees by doubleclicking in Customize Search

NEW
Unassigned

Status

SeaMonkey
Search
P3
normal
17 years ago
9 years ago

People

(Reporter: Blake Ross, Unassigned)

Tracking

Trunk
Future
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.21 KB, patch
Christopher Aillon (sabbatical, not receiving bugmail)
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

17 years ago
Standard windows behavior when you're transferring items between trees (or 
listboxes) is that you can double-click in one tree to send it to the other.  
We should support this in the Customize Search dialog.  For example, if you 
double-click on an item in the left tree, it should be moved to the right, and 
vice versa.

I talked to Brian (Ryner) about this, and he suggested you set onclick for the 
items and then check event.detail for the clickcount. You could also specify 
clickcount= in an XBL handler.  I'm not sure if treeitems fire ondblclick.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 48919 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
This is absolutely not a dup and a closer reading of the bug would have proven 
that.  Please dup-marking and verifying up to the QA contact if you aren't sure.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

17 years ago
No reason to get bent out of shape.  It would be helpful, if you are going to
file bugs with almost exactly the same summary, if you would make the summary
fit in the Bugzilla summary box.  That way we can see the whole thing at a
glance.  Otherwise, it's like one of those Sunday comic spot-the-changes games.

Sloppy job on the dup + vrfy, though.
Netscape nav triage team: as per Matt Fisher's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-

Comment 6

17 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future
(Reporter)

Comment 7

16 years ago
reassigning matt's old bugs to default owner.
Assignee: matt → sgehani
Status: REOPENED → NEW

Updated

15 years ago
Depends on: 171645

Updated

15 years ago
Blocks: 171645
No longer depends on: 171645
Created attachment 174864 [details] [diff] [review]
patch

This patch adds dblclick attributes to the appropriate listitem elements in
search-editor.xul that use the existing AddEngine and RemoveEngine functions in
search-editor.js to handle the event.
Assignee: samir_bugzilla → moz_bugzilla
Status: NEW → ASSIGNED
Attachment #174864 - Flags: superreview?(alecf)
Attachment #174864 - Flags: review?(caillon)
Attachment #174864 - Flags: review?(caillon) → review+
Attachment #174864 - Flags: superreview?(alecf) → superreview?(neil.parkwaycc.co.uk)

Comment 9

13 years ago
Comment on attachment 174864 [details] [diff] [review]
patch

Although generally I'm not a big fan of events on templated items as they
consume more memory.
Attachment #174864 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
Assignee: rob_strong → search
Status: ASSIGNED → NEW
QA Contact: claudius
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.