Behavior wrong when you close Firefox while other Firefox windows are open such as Library, View Source or multiple browser windows.

RESOLVED DUPLICATE of bug 354894

Status

()

RESOLVED DUPLICATE of bug 354894
10 years ago
10 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090420 Shiretoko/3.5b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090420 Shiretoko/3.5b4pre

Normally when you have multiple tabs open, Firefox 3.5b4pre will prompt you to "Save and Quit" or "Quit" when you click the X to close or select File->Exit.  However, if you have a "View Source" window open or the Library window open when you click the X or select File->Exit, Firefox 3.5b4pre just offers you to Quit, while warning you that you are going to close X amount of tabs. This problem is also present if you have multiple Firefox windows open with multiple tabs open in each window. If you go to close any of the windows, Firefox won't prompt you to save your tabs and quit. If this is a limitation of the session restore feature, functionality should be added to address restoring tabs from multiple browser windows (this functionality should already be present because when you press Ctrl-N to open a new Window, it doesn't spawn a new process).  

Reproducible: Always

Steps to Reproduce:
See Details.
Actual Results:  
See Details.

Expected Results:  
See Details.

If all that you have open besides your main Firefox browser window is View Source or your Library, Firefox should should prompt you to save your tabs when you exit the browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 354894
You need to log in before you can comment on or make changes to this bug.