Artifacts in some APNG frames

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: Andrew Smith, Assigned: Glenn Randers-Pehrson)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 373841 [details]
image to view to see the problem

I've got an email saying:

"Looks like that APNG bug has returned in 3.0.7 ...  Haven't tried 3.0.8 yet.
https://bugzilla.mozilla.org/show_bug.cgi?id=420416

And I've got one more sample. Most likely the same bug."

From the same guy who reported bug 420416. Attachment is attached.

Will try to get more information from the reporter. I haven't reproduced it myself (am on 3.0.5 on Linux).

Joe, do you want this one?
Reproducible in 3.1b3 as well.
(Reporter)

Comment 2

9 years ago
More info from the reporter
---------------------------

> Did you get a chance to try 3.0.8?

Yes, and I tried 3.0.9 too. Both buggy. It started with 3.0.7:

3.0.6 - ok
3.0.7 - buggy
3.0.8 - buggy
3.0.9 - buggy

> > I take it you're seing it on Windows?

Yes.

> > 

Also, that old image is in litmus test:
https://litmus.mozilla.org/show_test.cgi?id=5213

> > I hope to add more details from you and trying it myself (I'm on linux).

I remember that Glenn fixed it the last time by crearing prev_row
buffer before decoding the next frame.

I recently ran into the very similar looking problem in my little app
and also fixed it by clearing prev_row buffer.
Assignee: joe → nobody
(Assignee)

Updated

8 years ago
Blocks: 495609
(Assignee)

Comment 3

8 years ago
This works for me now, apparently fixed by the check-in of libpng-1.2.40 (bug #504805)
Assignee: nobody → glennrp+bmo
Depends on: 504805
Hardware: x86 → All
(Assignee)

Comment 4

7 years ago
Artifacts are still present in Firefox 3.6.16
(Assignee)

Comment 5

4 years ago
Works for me with the current nightly and with Firefox 24.0
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.