freezes while loading video then crashes while exiting (Move Networks player?) [@ memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)]

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
9 years ago
11 months ago

People

(Reporter: JPerry1218, Unassigned)

Tracking

({crash})

1.9.0 Branch
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9

The video at http://lds.org/move/index.html?type=conference04-2009&event=april179&lang=english will not completely load, freezes up, then when I attempt to exit Firefox crashes.  Happens every time. 

Reproducible: Always

Steps to Reproduce:
1.Go to http://lds.org/conference/languages/0,6353,310-1,00.html
2.Choose "English" from the choices displayed at the top of the page
3.When video freezes up hit the exit button
Actual Results:  
Firefox crashes back to my desktop and offers to send an error report.

Expected Results:  
Should have played video

This is something new in the last month.  Used to play videos on this link just fine.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Summary: freezes while loading video then crashes while exiting → freezes while loading video then crashes while exiting (Move Networks player?)

Comment 1

8 years ago
JP, can  you reproduce using FF 3.5?  if you can reproduce, a stack trace is needed https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

I crashed merely by going to the URL.
bp-0d29e40f-31dd-475e-b5e8-a96702100105
memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)
0	mozcrt19.dll	memmove	 MEMCPY.ASM:188
1	xul.dll	nsTArray_base::ShiftData	obj-firefox/xpcom/build/nsTArray.cpp:173
2	xul.dll	nsTArray<nsRefPtr<nsNavHistoryFolderResultNode> >::RemoveElementsAt	obj-firefox/dist/include/nsTArray.h:680
3	xul.dll	nsTArray<nsRefPtr<nsCookie> >::RemoveElementAt	obj-firefox/dist/include/nsTArray.h:685
4	xul.dll	nsCookieService::RemoveCookieFromList	
5	xul.dll	nsCookieService::PurgeCookies	netwerk/cookie/src/nsCookieService.cpp:2389
6	xul.dll	nsCookieService::AddInternal	
7	xul.dll	nsCookieService::SetCookieInternal	netwerk/cookie/src/nsCookieService.cpp:1572
8	xul.dll	nsCookieService::SetCookieStringInternal	netwerk/cookie/src/nsCookieService.cpp:854
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: freezes while loading video then crashes while exiting (Move Networks player?) → freezes while loading video then crashes while exiting (Move Networks player?) [@ memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)]
Version: unspecified → 1.9.0 Branch
(Assignee)

Updated

7 years ago
Crash Signature: [@ memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)]

Updated

2 years ago
Crash Signature: [@ memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)] → [@ memmove | nsTArray_base::ShiftData(unsigned int, unsigned int, unsigned int, unsigned int)] [@ memmove | nsTArray_base::ShiftData]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year) [except some obsolete <4 versions, no crashes starting since 4 version].
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.