Including the function of "Right Encoding"

RESOLVED DUPLICATE of bug 240301

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 240301
9 years ago
9 years ago

People

(Reporter: Chan Tsz Kin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; zh-TW; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; zh-TW; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9

Right Encoding in European or white man society may be unuseful since the coding system can be easily detected by Firefox.
But in Chinese, the two main coding system such as BIG5 and GB code. They use the same code to present different character. If Firefox detects error, the strange and meaningless character appeared, the error coding system being chosen.
There is also another problem in frameset, the embedded view->coding system cannot satisfy more than one frame.
On the other hand, the webpage without the toolbar or menu, it will difficult for user to change the coding system.
Installion of Right Encoding is a way, but it should be the basic function of a browser. Internet Explorer includes this function BUT Firefox not!!! Suck for Chinese and Asian!!!

Reproducible: Always

Steps to Reproduce:
1.Install Right Encoding
2.Use other browsers
3.Install Character Swithcher
Actual Results:  
1,3. Too complex, not friendly for NEW user
2. I love Firefox, I wouldn't use others to replace Firefox!!!

Expected Results:  
The function of Right Encoding will be included in right-click menu.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 240301
You need to log in before you can comment on or make changes to this bug.