setting name of iframe by JS does not affect links with target

RESOLVED DUPLICATE of bug 161061

Status

()

Core
DOM: Core & HTML
--
minor
RESOLVED DUPLICATE of bug 161061
9 years ago
6 years ago

People

(Reporter: André Hänsel, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729) FirePHP/0.2.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729) FirePHP/0.2.4

When I use
iframe_obj.name = 'something';
to set the name of an iframe, links with target="something" are not loaded into that iframe but in a new tab.

Reproducible: Always

Steps to Reproduce:
1. Navigate to given sample URL
2. Click first link
3. Click second link ;)
Actual Results:  
The links href URL is loaded into a new tab.

Expected Results:  
The links href URL is loaded into the iframe.
Opera is the only browser that shows the desired behaviour.
Status: UNCONFIRMED → NEW
Component: General → DOM: Core & HTML
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
Keywords: testcase

Comment 2

8 years ago
Duplicate of/related to Firefox bug 455875?
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 161061
You need to log in before you can comment on or make changes to this bug.