Closed Bug 489951 Opened 11 years ago Closed 11 years ago

[TSF] Korean TIP's composition string looks like normal text

Categories

(Core :: Internationalization, defect, major)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: masayuki, Assigned: masayuki)

References

Details

(Keywords: inputmethod, regression)

Attachments

(1 file, 1 obsolete file)

Attached patch Patch v1.0 (obsolete) — Splinter Review
This is regression of bug 482138.

Korean TIP specifies no change style (i.e., it said "don't change foreground color, background color and don't draw underline") to its composition string. And it calls SetSelection with non-collapsed range. Other TSF aware application uses wide caret at this time. I.e., the all selected text is blinking by the caret. We cannot use the wide caret, because we don't implement that. And also Gecko1.9 and later version cannot use XOR drawing.

This is serious accessibility problem. For now, we should not honor the specified style by TIP at this time.
Attachment #374416 - Flags: review?(VYV03354)
Attached patch Patch v2.0Splinter Review
Alternative patch for Kimura-san's suggestion.
Attachment #374569 - Flags: review?(VYV03354)
Attachment #374569 - Flags: review?(VYV03354) → review+
Attachment #374416 - Attachment is obsolete: true
Attachment #374416 - Flags: review?(VYV03354)
Attachment #374569 - Flags: superreview?(roc)
roc, would you sr this?
Attachment #374569 - Flags: superreview?(roc) → superreview+
http://hg.mozilla.org/mozilla-central/rev/422c2a0c712b
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.