Closed Bug 489994 Opened 11 years ago Closed 10 years ago

Downloads list should honor always remember helper application

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: timeless, Assigned: timeless)

References

()

Details

Attachments

(1 file, 1 obsolete file)

preconditions:
1. msword installed and set in windows as the default .rtf handler
2. mswordviewer installed

steps:
1. load data:application/rtf,hi
2. when asked what to do, select browse and select Word Viewer
3. select always remember.
4. select ok
5. open downloads
6. double click the rtf item

expected results:
4, 6 - opens word viewer w/ the rtf document

actual results:
4 - opens word viewer
6 - opens word
Bug 489994 Downloads list should honor always remember helper application
Attachment #374472 - Flags: review?(mconnor)
This isn't a core issue.
Product: Core → Firefox
QA Contact: file-handling → file.handling
This isn't just a Firefox issue either.
Component: File Handling → Download Manager
Product: Firefox → Toolkit
QA Contact: file.handling → download.manager
So, one problem is that we'll set icons based on the OS handler for that type of file.  That means that this UI will be more confusing than it already is.

My current preference is actually to go in the other direction, namely to minimize/deprecate our own file type infrastructure in favour of just following the OS level stuff.  It's hugely frustrating to have to change something in the OS and in Firefox every time I try out a new video player, as a counter-example.  I think that "Word Viewer for browsing, Word for editing" is more of a power user edge case than anything, and I think this probably goes in the wrong direction.
I think this might be a dupe, but I'm not 100% sure...
Whiteboard: DUPEME?
sdwilsh: i'd expect it's a dupe, i wouldn't be shock if it was a dupe of a bug i filed. i just needed a place to post the patch.

mconnor: we could pull in the icon from the app instead, however i don't think that's a problem. just because a file has icon <x> doesn't mean it will open app <x> even without a helper application.
If the file in the download manager has an icon, it's coming from the OS, typically (except for executables, iirc).  If my DM has a VLC icon, I expect it to open in VLC...
mconnor: well, how many helper apps have you registered?

for me, and technically for everyone, icons are not actually tied to applications. they're slightly distinct as a user can change the app icon (quite easily in windows explorer) and leave the association or change the association (again easily in windows explorer) and leave the icon.

atm, in Camino, all of my download icons are question marks, I don't expect Camino to open Help :). [The reason they have that icon is because I deleted the items ....]

As things stand today, I checked an [x] always use this app to handle this file type, and firefox is ignoring my preference.
Comment on attachment 374472 [details] [diff] [review]
honor always remember helper applpication

I can't find a downloads.js that this applies to (on trunk or any active branches), and it seems to be introducing a code path that calls both launchWithFile(f) and f.launch(), which doesn't seem right.
Attachment #374472 - Attachment is obsolete: true
Attachment #374472 - Flags: review?(mconnor)
oops, i forgot to qfold the previous patch layer :)
Assignee: nobody → timeless
Status: NEW → ASSIGNED
Attachment #375579 - Flags: review?(mconnor)
Comment on attachment 375579 [details] [diff] [review]
honor always remember helper application

Given the current continued existence of our crazy preferred application setup, this is fine, but we should kill this feature in 3.7. :)
Attachment #375579 - Flags: review?(mconnor) → review+
Keywords: checkin-needed
Whiteboard: DUPEME?
http://hg.mozilla.org/mozilla-central/rev/c1edda3124be
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
You need to log in before you can comment on or make changes to this bug.