If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Memory utilization randomly jumps to 2GB when refreshing facebook.com news feed today in Firefox 3.0.9

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Jim Laux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.9) Gecko/2009040821 Firefox/3.0.9 (.NET CLR 3.5.30729)

Twice today Firefox 3.0.9 has jumped to 2GB memory utilization when refreshing the news feed on Facebook.  Overall system performance is sluggish during this occurrence.  The first time Firefox recovered after a few minutes and returned to normal memory utilization (perhaps 200M overall), the second time (several hours later) it crashed but was unsuccessful in sending the crash report.  

Reproducible: Sometimes

Steps to Reproduce:
1. Open Firefox
2. Log into Facebook.com
3. Refresh news feed
Actual Results:  
Issue has occurred twice in perhaps 20 or 30 refreshes today.

Expected Results:  
Maintained normal memory utilization and not crashed.

The issue appears to be new today.  I recently filtered out the "LivingSocial" application from the Facebook news feed so that it no longer appears -- perhaps this filtering is resulting in some dodgy code coming from Facebook's end.  I did not observe a module name when Firefox crashed.
DId you already tried to reproduce it in the Firefox safemode ?
http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 2

9 years ago
I haven't.  The crash occurred again just now, but apparently the crash reporter failed again as well.  The following information was in the clipboard:

Add-ons: {ab8568cd-1789-4fc8-a530-218e9eab17e2}:0.2.9,{b9db16a4-6edc-47ec-a1f4-b86292ed211d}:4.3,{11483926-db67-4190-91b1-ef20fcec5f33}:0.2.3,{CAFEEFAC-0016-0000-0001-ABCDEFFEDCBA}:6.0.01,{CAFEEFAC-0016-0000-0003-ABCDEFFEDCBA}:6.0.03,{20a82645-c095-46ed-80e3-08825760534b}:1.0,unplug@compunach:2.003,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.0.9
BuildID: 2009040821
CrashTime: 1240676956
InstallTime: 1240437095
ProductName: Firefox
SecondsSinceLastCrash: 76281
StartupTime: 1240632872
Theme: classic/1.0
URL: http://www.facebook.com/home.php#/home.php?ref=logo
Vendor: Mozilla
Version: 3.0.9

If there are any additional logs I can submit I'd be happy to do so.
A crash report is only useful if the crash server receives your report because the crash report on your system must be merged with the information from the crash server. For a successful sent report we need only the crash id from about:crashes. https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report )
High memory usage is often caused by addons, that's the reason why we must be sure that you get this without addons.
(Reporter)

Comment 4

9 years ago
This was fixed either by the 3.0.10 update or changes on the Facebook site.  I'm not experiencing the issue anymore.  Thanks for your help.
thanks for the response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.