We crash after showing any modal dialog

RESOLVED FIXED

Status

()

P3
blocker
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: mscott, Assigned: hyatt)

Tracking

({crash})

Trunk
All
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
With a tree pulled just before the network went down, I'm repeatedly crashing
after we show a modal dialog after parsing htmlbindings.xml.

We crash in nsXBLStreamListener::Load. This crash happens after I dimiss the dialog.

nsXBLStreamListener::Load(nsIDOMEvent * 0x053f97b4) line 311 + 45 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x00000000, nsEvent *
0x0012f8a4, nsIDOMEvent * * 0x0012f874, nsIDOMEventTarget * 0x053fac5c, unsigned
int 7, nsEventStatus * 0x0012f8e8) line 1320 + 23 bytes
nsDocument::HandleDOMEvent(nsDocument * const 0x053fac30, nsIPresContext *
0x00000000, nsEvent * 0x0012f8a4, nsIDOMEvent * * 0x0012f874, unsigned int 1,
nsEventStatus * 0x0012f8e8) line 3085
nsXMLDocument::EndLoad(nsXMLDocument * const 0x053fac30) line 617
nsXMLContentSink::StartLayoutProcess() line 327
nsXMLContentSink::DidBuildModel(nsXMLContentSink * const 0x053fbdb0, int 1) line 313
CWellFormedDTD::DidBuildModel(CWellFormedDTD * const 0x053fca60, unsigned int
2152398850, int 1, nsIParser * 0x053fa570, nsIContentSink * 0x053fbdb0) line 293
+ 20 bytes
nsParser::DidBuildModel(unsigned int 2152398850) line 1389 + 60 bytes
nsParser::ResumeParse(int 1, int 1) line 1914
nsParser::OnStopRequest(nsParser * const 0x053fa578, nsIChannel * 0x053fa710,
nsISupports * 0x00000000, unsigned int 2152398850, const unsigned short *
0x100a1088 gCommonEmptyBuffer) line 2353 + 19 bytes
nsXBLStreamListener::OnStopRequest(nsXBLStreamListener * const 0x053fbaf0,
nsIChannel * 0x053fa710, nsISupports * 0x00000000, unsigned int 2152398850,
const unsigned short * 0x100a1088 gCommonEmptyBuffer) line 273 + 42 bytes
nsResChannel::EndRequest(unsigned int 2152398850, const unsigned short *
0x100a1088 gCommonEmptyBuffer) line 708 + 50 bytes
nsResChannel::OnStopRequest(nsResChannel * const 0x053fa714, nsIChannel *
0x053fb2a0, nsISupports * 0x00000000, unsigned int 2152398850, const unsigned
short * 0x100a1088 gCommonEmptyBuffer) line 702
nsFileChannel::OnStopRequest(nsFileChannel * const 0x053fb2a8, nsIChannel *
0x053fb060, nsISupports * 0x00000000, unsigned int 2152398850, const unsigned
short * 0x100a1088 gCommonEmptyBuffer) line 632 + 45 bytes
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x053fc300) line 302
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x053fc4b0) line 97 + 12 bytes
PL_HandleEvent(PLEvent * 0x053fc4b0) line 587 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x04ab1530) line 528 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x0423067c, unsigned int 49325, unsigned int 0,
long 78320944) line 1043 + 9 bytes
(Reporter)

Comment 1

18 years ago
adding appropriate keywords.

Severity: normal → blocker
Keywords: smoketest
Hardware: PC → All

Comment 2

18 years ago
I'm wondering if this could be related to bug 48987, which no one else (but me) 
could reproduce.

Comment 3

18 years ago
Can't reproduce on Linux 2000-08-14-12.
Keywords: crash
(Assignee)

Comment 4

18 years ago
This only happens with the XUL cache disabled.
(Assignee)

Updated

18 years ago
Keywords: smoketest
(Assignee)

Comment 5

18 years ago
I'm removing this as a smoketest blocker.  It only happens when the XUL cache is 
disabled.
(Assignee)

Comment 6

18 years ago
Ok, since developers are saying it *is* serious, here's a fix that at least 
stops the crash.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.