Apprunner takes forever to launch on my win95 machine

VERIFIED FIXED in M9

Status

SeaMonkey
Sidebar
P3
critical
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: Paul MacQuiddy, Assigned: James Everingham)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf])

(Reporter)

Description

20 years ago
Apprunner takes way too long to launch on my win95 P133 with 80Mb RAM. At least
a minute. Very painful. This is not just the very first time a run a new build.
There is not a whole lot of disk activity going on, so it doesn't seem to be
re-registering the dll's or anything like that.

Nobody else has reported this. I would like to understand more about what
happens during launch to figure out why this is happening.
(Reporter)

Updated

20 years ago
QA Contact: 3853 → 3819
(Reporter)

Comment 1

20 years ago
note: it takes viewer about 7 seconds to launch, about 10-15 times as fast.
(Reporter)

Comment 2

20 years ago
It looks like installing java is the culprit. Without java installed I launch in
about 25 seconds.  With java installed it takes over a minute to launch. CC'ing
alex to see if he knows why this is happening.

Note: this happens both on my machine at home and at work.

Comment 3

20 years ago
Yes.  You need to turn off Java.  Initial Launch and re-launch times will be
included in PageLoadMetrics starting with 04/23 report.  Let's see how we look
after that report.

But paulmac, I think this is a lot faster with M4 build.  NO?

Comment 4

20 years ago
In order to hook up LiveConnect, we need to load Java at startup, which means
loading plugins at startup.  The plugins do get unloaded, but it takes time.

I'll look into delaying this action until we need it.  Maybe Patrick can also
chime in here on delaying the init of LC since he hooked it up.
(Reporter)

Comment 5

20 years ago
in response to Jan's question, no, I haven't noticed any speed up in M4 builds.
Still takes up to two minutes to launch, and about 30 seconds if I rename my
Communicator plugins directory so seamonkey can't find it.

Updated

19 years ago
Target Milestone: M6

Comment 6

19 years ago
paulmac, how ya feeling about launch time recently?
(Reporter)

Comment 7

19 years ago
I would say it has gotten worse. It takes me on average about 2 minutes to start
up on my P133 at work. This includes loading sidebar and the default smoketest
home page, although loading the smoketest page separately only take 15-20
seconds. This is also with no Communicator Plug-ins directory present.

Updated

19 years ago
Severity: normal → critical
Target Milestone: M6 → M7

Comment 8

19 years ago
M7 will be the push for performance and we are doing extra tests with Viewer
too.  Moving this bug to M7.

Updated

19 years ago
Whiteboard: [Perf]

Comment 9

19 years ago
Putting on [Perf] radar

Updated

19 years ago
Component: Apprunner → Sidebar
(Reporter)

Comment 10

19 years ago
I've figured out an interesting way to improve start-up performance on
my win95 machine. It seems to cut my start-up time from about 1:30 to
:30. Normally on my machine there is about a one minute hang after the
initial browser window is drawn. However, if I, just after the browser
window is drawn, click on the apprunner MSDOS window in the windows
taskbar to put focus back in the console, there is virtually no delay
and the start-up page is loaded pretty quickly.

This is 100% reproducible. Anyone have any ideas?
(Assignee)

Comment 11

19 years ago
I tried clicking on the apprunner ms-dos prompt on my machine and the startup
time is identical.  Maybe your graphics card is older and your drivers dont
support clipping well or something.  Strange.
(Reporter)

Comment 12

19 years ago
Interesting enough, the minute delay happens on 6/7 builds but not 6/8 builds.
The only noticeable difference is that talkback is broken in 6/8 builds. Hmmmm.
(Reporter)

Comment 13

19 years ago
Delay is back on 6/9 builds. However, running apprunner.exe >nul from the
command line, as opposed to apprunner.exe from an icon on the desktop, decreases
start-up time (on my work machine, P133) from 2:15 to :45. Jim is so smart.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7 → M8
(Assignee)

Comment 14

19 years ago
This is due to all of the printf's being used instead of PR_Log calls.  This
will have to fixed for M8 and over a period of time.
(Assignee)

Updated

19 years ago
Target Milestone: M8 → M9

Updated

19 years ago
Blocks: 7251
(Reporter)

Comment 15

19 years ago
marking this bug fixed, most of the remaining start-up issues are covered in
other bugs
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 7251
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.