Closed Bug 490124 Opened 11 years ago Closed 11 years ago

Firefox presents "File Chooser" dialogue when it should present "Open With" dialogue

Categories

(Firefox :: File Handling, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 397700

People

(Reporter: mozilla-bugs-2011.08, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.9) Gecko/2009042113 Ubuntu/9.04 (jaunty) Firefox/3.0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.9) Gecko/2009042113 Ubuntu/9.04 (jaunty) Firefox/3.0.9

When Firefox encounters a filetype that it is unfamiliar with, the user is presented the "File Chooser" dialogue box, instead of the "Open With" dialogue. This confuses new users, who are expecting a list of installed programs to choose from. Many users do not know that they cant navigate the File Chooser to /usr/bin/ and even if they know that much, they likely do not know the name of the executable they need. When Firefox encounters a new file type, the user be presented with the same dialogue box that is presented when choosing "Open With" from a file manager's context menu, with a list of available programs.

Reproducible: Always

Steps to Reproduce:
1) Click to download this file (Firefox should be configured not to handle PDF files):
http://www.ghacks.net/wp-content/uploads/2009/01/ghacks-linux-pdf-december-2008.pdf
2) The "What should Firefox do with this file" dialogue should open.
3) Choose Open With -> Other
Actual Results:  
The user is presented with the "File Chooser" dialogue.

Expected Results:  
The user should be presented with the same dialogue that he would get if he chose "Open With -> Other" from the context menu of his file manager.
Component: General → File Handling
QA Contact: general → file.handling
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 397700
You need to log in before you can comment on or make changes to this bug.