First characters of each lines in non-ASCII pages are missing

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Takuro Ashie, Assigned: Takuro Ashie)

Tracking

({fonts})

Bug Flags:
wanted-fennec1.0 +
in-testsuite ?

Details

Attachments

(5 attachments)

(Assignee)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; ja; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: 

When I open a certain page such as http://www.yahoo.co.jp, first character of all lines are missing.
This issue occurs with most Japanese page.


Reproducible: Always

Steps to Reproduce:
1. Open http://www.yahoo.co.jp by Fennec on WinCE
2. Open http://www.yahoo.co.jp by Firefox on Windows XP
3. Compare both results (characters count of each lines)

Actual Results:  
First character of each lines are missing.

Expected Results:  
Both results should be corresponded.
(Assignee)

Updated

9 years ago
OS: Other → Windows Mobile 6 Professional
Hardware: Other → ARM
(Assignee)

Comment 1

9 years ago
Created attachment 374735 [details]
A screen shot of expected result (Firefox)
(Assignee)

Comment 2

9 years ago
Created attachment 374736 [details]
A screen shot of result on Fennec
(Assignee)

Comment 3

9 years ago
Created attachment 374737 [details]
Sample screen shot of result on fennec (with japanese font)

This screen shot uses Japanese font and a patch for https://bugzilla.mozilla.org/show_bug.cgi?id=490267 to show Japanese characters.
(Assignee)

Comment 4

9 years ago
Created attachment 374739 [details]
Another sample screen shot with default font settings

An interesting thing is that this issue doesn't occur when I specify default font by prefs.js and userContent.css.

prefs.js:

  user_pref("font.name.sans-serif.ja", "vl pgothic");
  user_pref("font.name.sans-serif.x-unicode", "vl pgothic");
  user_pref("font.name.sans-serif.x-western", "vl pgothic");
  user_pref("font.name.serif.ja", "vl pgothic");
  user_pref("font.name.serif.x-unicode", "vl pgothic");
  user_pref("font.name.serif.x-western", "vl pgothic");

userContent.css:

  input[name], input[value], select[name], option, textarea, button, fieldset, label, legend, optgroup[label] {
    font-family: 'VL PGothic', sans-serif;
    font-size: 12px;
  }

You can obtain VL PGothic from here:

  http://dicey.org/vlgothic/
(Assignee)

Updated

9 years ago
Summary: Some characters are gone on WinCE → First characters of each lines in non-ASCII pages are missing
(Assignee)

Comment 5

9 years ago
Created attachment 375303 [details] [diff] [review]
A patch for missing characters issue

I've fixed this issue.

The problem is that all GlyphRuns in a TextRun is started from first character for the TextRun.

  http://hg.mozilla.org/mozilla-central/file/051f635a1061/gfx/thebes/src/gfxFT2Fonts.cpp#l550

So that later GlyphRuns erases/overrides former GlyphRuns, and finally only the last GlyphRuns is available in the TextRun.

I think it's a fatal issue for multiligual layout.
(Assignee)

Updated

9 years ago
Attachment #375303 - Flags: review?(vladimir)
Attachment #375303 - Flags: review?(vladimir)
Attachment #375303 - Flags: review?(mozbugz)
Attachment #375303 - Flags: review+
Comment on attachment 375303 [details] [diff] [review]
A patch for missing characters issue

I think this is right, but I'd like karl or someone closer to the font code to also take a glance.
Attachment #375303 - Flags: review?(mozbugz) → review+
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(Assignee)

Updated

9 years ago
Flags: wanted-fennec1.0?
Keywords: fonts
Assignee: nobody → ashie
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
tracking-fennec: --- → 1.0-wm+
Flags: wanted-fennec1.0? → wanted-fennec1.0+
(Assignee)

Updated

9 years ago
Attachment #375303 - Flags: superreview?(roc)
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
(Assignee)

Updated

9 years ago
Attachment #375303 - Flags: superreview?(roc)
(Assignee)

Updated

9 years ago
Keywords: checkin-needed
Do we need a test here? Do reftests actually pass on this platform without this patch?
Flags: in-testsuite?
http://hg.mozilla.org/mozilla-central/rev/d72e4c13d38e

Thanks, sorry about the delay.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (Macintosh; U; Intel Mac OSX 10.5; en-US; rv:1.9.2a2pre)
Gecko/20090808 Fennec/1.0b3pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20090820
Fennec/1.0b3pre
Status: RESOLVED → VERIFIED
OS: Windows Mobile 6 Professional → All
Hardware: ARM → All
You need to log in before you can comment on or make changes to this bug.