Last Comment Bug 490384 - mochitest-plain: random "test_bug466586.html | undefined"
: mochitest-plain: random "test_bug466586.html | undefined"
Status: VERIFIED FIXED
[fixed in 3.6a1: A to C; 12a1: Dv1a] ...
: intermittent-failure
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86 Windows Server 2003
: -- normal (vote)
: mozilla12
Assigned To: Joe Drew (not getting mail)
:
: Milan Sreckovic [:milan]
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on: 466586 483407
Blocks: 438871
  Show dependency treegraph
 
Reported: 2009-04-27 18:41 PDT by Serge Gautherie (:sgautherie)
Modified: 2012-11-25 19:31 PST (History)
12 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Only evict unused cache entries on memory-pressure [Checked in: Comment 16] (4.97 KB, patch)
2009-05-06 17:13 PDT, Joe Drew (not getting mail)
vladimir: review+
Details | Diff | Splinter Review
(Dv1) Improve and reenable test_bug466586.html [Checked in: See comment 24] (2.43 KB, patch)
2012-01-20 19:13 PST, Serge Gautherie (:sgautherie)
joe: review+
Details | Diff | Splinter Review

Description User image Serge Gautherie (:sgautherie) 2009-04-27 18:41:22 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1240875637.1240881088.1852.gz
WINNT 5.2 mozilla-central unit test on 2009/04/27 16:40:37

*** 74506 INFO TEST-PASS | /tests/modules/libpr0n/test/mochitest/test_bug399925.html | got different rendered results
*** 74508 INFO Running /tests/modules/libpr0n/test/mochitest/test_bug466586.html...
*** 74509 ERROR TEST-UNEXPECTED-FAIL | /tests/modules/libpr0n/test/mochitest/test_bug466586.html | undefined
*** 74511 INFO Running /tests/modules/libpr0n/test/mochitest/test_bug468160.html...
Comment 1 User image :Ehsan Akhgari (in Taipei, laggy response time) 2009-04-29 06:49:58 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1240981621.1240989828.24346.gz
WINNT 5.2 mozilla-central unit test on 2009/04/28 22:07:01

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241003221.1241008296.19439.gz
WINNT 5.2 mozilla-central unit test on 2009/04/29 04:07:01
Comment 3 User image Jesse Ruderman 2009-05-01 08:59:18 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241180887.1241186567.14524.gz
WINNT 5.2 mozilla-central unit test on 2009/05/01 05:28:07
Comment 4 User image Daniel Holbert [:dholbert] (away, returning Jan 17) 2009-05-04 13:04:57 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241455303.1241463963.12818.gz
WINNT 5.2 mozilla-central unit test on 2009/05/04 09:41:43
Comment 5 User image Matthew Gregan [:kinetik] 2009-05-05 00:48:31 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241504362.1241509277.9313.gz
WINNT 5.2 mozilla-central unit test on 2009/05/04 22:05:35
Comment 6 User image Joe Drew (not getting mail) 2009-05-05 08:28:18 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241499935.1241509041.8931.gz
WINNT 5.2 mozilla-central unit test on 2009/05/04 22:05:35
Comment 7 User image Daniel Holbert [:dholbert] (away, returning Jan 17) 2009-05-06 11:05:09 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241600279.1241608318.12465.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 01:57:59

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241622170.1241630405.24505.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 08:02:50
Comment 8 User image Daniel Holbert [:dholbert] (away, returning Jan 17) 2009-05-06 11:08:22 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241614679.1241623545.11790.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 05:57:59

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241620685.1241625574.15171.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 07:38:05

This has failed in 5 out of the last 7 cycles on this box..
Comment 9 User image David Baron :dbaron: ⌚️UTC-8 2009-05-06 14:46:03 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241636328.1241646124.19209.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 11:58:48
Comment 10 User image David Baron :dbaron: ⌚️UTC-8 2009-05-06 15:27:56 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241640909.1241647021.20622.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 13:15:09
Comment 11 User image Joe Drew (not getting mail) 2009-05-06 17:13:34 PDT
Created attachment 376127 [details] [diff] [review]
Only evict unused cache entries on memory-pressure
[Checked in: Comment 16]

The only reason I currently see for this to randomly fail is if we're getting the memory-pressure signal after loading big.png. (This actually makes a whole lot of sense, because big.png is 3000x3000.)

On memory pressure we shouldn't remove entries from the cache that are currently being used, since that won't actually free any memory: something other than the cache has a reference to the imgRequest.

This patch makes memory pressure only remove entries in the cache's "removal queue," further fixing bug 466586 (albeit in an uncommon circumstance).
Comment 12 User image Ted Mielczarek [:ted.mielczarek] 2009-05-06 17:22:34 PDT
If this fixes it, can we put this on a wall somewhere under the category "flaky tests that turned out to be exposing platform bugs"? :)
(Also: good catch!)
Comment 13 User image Josh Aas 2009-05-06 22:55:50 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241670041.1241674730.26157.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 21:20:41
Comment 14 User image Josh Aas 2009-05-06 23:28:35 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241670342.1241676977.28862.gz
WINNT 5.2 mozilla-central unit test on 2009/05/06 21:25:42
Comment 17 User image Josh Aas 2009-05-08 09:24:15 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1241790538.1241797917.27937.gz
WINNT 5.2 mozilla-central unit test on 2009/05/08 06:48:58
Comment 18 User image Joe Drew (not getting mail) 2009-05-08 14:44:47 PDT
I've disabled the ok() call in the test, because it's just too faily at the moment. This bug will remain open until I can work out why it's failing.

http://hg.mozilla.org/mozilla-central/rev/930e980cae1c
Comment 19 User image Serge Gautherie (:sgautherie) 2009-05-11 20:21:09 PDT
(In reply to comment #18)
> I've disabled the ok() call in the test

Need to replace it with something else, for bug 483407.

{
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1242092605.1242096280.17513.gz&fulltext=1
OS X 10.5.2 mozilla-central unit test on 2009/05/11 18:43:25

*** 74788 INFO Running /tests/modules/libpr0n/test/mochitest/test_bug466586.html...
*** 74789 INFO TEST-KNOWN-FAIL | /tests/modules/libpr0n/test/mochitest/test_bug466586.html | [SimpleTest.report()] No checks actually run.
}
Comment 20 User image Joe Drew (not getting mail) 2009-05-11 21:08:47 PDT
Done - http://hg.mozilla.org/mozilla-central/rev/d68c8315b785
Comment 21 User image Benoit Girard (:BenWa) 2012-01-20 11:43:11 PST
(In reply to Joe Drew (:JOEDREW!) from comment #18)
> I've disabled the ok() call in the test, because it's just too faily at the
> moment. This bug will remain open until I can work out why it's failing.
> 

Still disabled in image/test/mochitest/test_bug466586.html. Still want this open Joe?
Comment 22 User image Serge Gautherie (:sgautherie) 2012-01-20 19:13:09 PST
Created attachment 590412 [details] [diff] [review]
(Dv1) Improve and reenable test_bug466586.html
[Checked in: See comment 24]

Let's try and see whether this bug still happens.

If it does, we should work around it on Windows only.
Comment 23 User image Joe Drew (not getting mail) 2012-01-23 12:49:55 PST
Comment on attachment 590412 [details] [diff] [review]
(Dv1) Improve and reenable test_bug466586.html
[Checked in: See comment 24]

Review of attachment 590412 [details] [diff] [review]:
-----------------------------------------------------------------

::: image/test/mochitest/test_bug466586.html
@@ +13,4 @@
>  <a target="_blank" href="https://bugzilla.mozilla.org/show_bug.cgi?id=89419">Mozilla Bug 466586</a>
>  <p id="display"></p>
>  <div id="content" style="display: none">
> +  <img id="big" src="big.png" style="width: 100px; height: 100px"/>

Remove the style (width and height) here. This breaks the test if the content div is displayed.
Comment 24 User image Serge Gautherie (:sgautherie) 2012-01-23 22:11:37 PST
Comment on attachment 590412 [details] [diff] [review]
(Dv1) Improve and reenable test_bug466586.html
[Checked in: See comment 24]

https://hg.mozilla.org/mozilla-central/rev/c1fd381a7faa
Dv1, with comment 23 suggestion(s).


(In reply to Joe Drew (:JOEDREW!) from comment #23)
> Remove the style (width and height) here. This breaks the test if the
> content div is displayed.

Right, .width would return 100 in that case.
Comment 25 User image Serge Gautherie (:sgautherie) 2012-01-23 23:52:06 PST
https://tbpl.mozilla.org/php/getParsedLog.php?id=8780435&tree=Firefox&full=1
Rev3 WINNT 6.1 mozilla-central opt test mochitests-4/5 on 2012-01-23 23:10:53 PST for push 3be494e4cc8f
{
169 INFO TEST-START | /tests/image/test/mochitest/test_bug466586.html
170 INFO TEST-PASS | /tests/image/test/mochitest/test_bug466586.html | HTML 'big' image width after page onload() - 3000 should equal 3000
171 INFO TEST-PASS | /tests/image/test/mochitest/test_bug466586.html | JS 'big' image width before its onload() - 3000 should equal 3000
172 INFO TEST-PASS | /tests/image/test/mochitest/test_bug466586.html | JS 'big' image width after its onload() - 3000 should equal 3000
173 INFO TEST-END | /tests/image/test/mochitest/test_bug466586.html | finished in 328ms
}

V.Fixed

Note You need to log in before you can comment on or make changes to this bug.