Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 463027
11 years ago
11 years ago

People

(Reporter: ben.bradshawuk, Unassigned)

Tracking

3.5 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

Steps to re-create.

1 - open Firefox - click private browsing.
2 - browse sites on private browsing.

Now I want to open a non private browsing web page, so i right click the firefox icon in the task bar - and click Firefox - this opens a new browser window - i then untick the menu option to turn private browsing off - it closes all the open private browsing windows that i had on previously in the different window.

Private browsing should be per -page or set of tabs dependently and not overall-session dependant.




Reproducible: Always

Steps to Reproduce:
Steps to re-create.

1 - open Firefox - click private browsing.
2 - browse sites on private browsing.

Now I want to open a non private browsing web page, so i right click the firefox icon in the task bar - and click Firefox - this opens a new browser window - i then untick the menu option to turn private browsing off - it closes all the open private browsing windows that i had on previously in the different window.

Private browsing should be per -page or set of tabs dependently and not overall-session dependant.

Actual Results:  
losing webpages, loss of functionality.

Expected Results:  
It should of just opened up a non private browsing window in the new firefox window i opened up, and should close other private browsing windows when i untick the option in the separate window.
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: PBnGen
You need to log in before you can comment on or make changes to this bug.