Firefox closes when last tab is closed

RESOLVED DUPLICATE of bug 456405

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 456405
9 years ago
9 years ago

People

(Reporter: pic2021, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

I found that this is one feature in beta 4 that i just cannot work with. I may even stay with the actual build (firefox 3) that is out right now because this feature i cannot stand. 

When you have one window left open and you Ctrl + F4 that tab it also closes down firefox, i really do not like that and would love to know if you guys can put it back to where once you close the last tab it goes to a white tab and leaves that open until you proceed to a site. Internet explorer does that last tab/closing thing and i cant believe ff is doing what they do :/ that is the omly thing i dont like and to me that is a major bug, can you fix it now?

Reproducible: Always

Steps to Reproduce:
1. Open up a tab
2. Ctrl + F4 that tab
3. Everything closes :|
Actual Results:  
Firefox go bye bye and i have to open up a new one.


Please fix it... now.
You can change this in about:config. It's "browser.tabs.closeWindowWithLastTab", set it to false and you'll have the behavior you like.
bug456382#c42
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392870

Updated

9 years ago
Duplicate of bug: 456405
(Reporter)

Comment 4

9 years ago
hmmm that line "browser.tabs.closeWindowWithLastTab" wasn't in the config file, and im just gonna ignore these duplicate posts because they are striked out? and i dont know if this issue was addressed. so any ideas?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to comment #4)
> and im just gonna ignore these duplicate posts because they are striked out?

They are struck through because they are resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456405
You need to log in before you can comment on or make changes to this bug.