'Change Several Bugs at Once' should be context sensitive

RESOLVED DUPLICATE of bug 322253

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED DUPLICATE of bug 322253
9 years ago
9 years ago

People

(Reporter: Scott Weber, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: 3.2.3

Currently, when you hit the "Change Several Bugs At Once" link, some of the options for changing (e.g. Status, Target Milestone, etc.) are limited to only those choices that are applicable for all bugs in the search results.  I would like to see these lists instead limited to those choices that are applicable for all bugs that are actually selected (checked).

For example, if my search returns five bugs, three of which are RESOLVED, and two are NEW, if I only check the three that are RESOLVED, I should be able to change the Status to VERIFIED.

Reproducible: Always

Steps to Reproduce:
1. Run a search that returns bugs in multiple different statuses.
2. Choose the "Change Several Bugs At Once" link.
3. Check a couple of bugs that are in the RESOLVED status.
4. Note that you cannot change the status of those bugs to VERIFIED because VERIFIED is not available in the Status drop down.



Current workaround is to do a new search that only pulls the items you are interested in changing.  This can be cumbersome, especially if I've already got the items I'm interested in in my current result set.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 322253
You need to log in before you can comment on or make changes to this bug.