Closed Bug 490504 Opened 12 years ago Closed 12 years ago

privacy.item.cookies default change causes unexpected cookie loss when upgrading

Categories

(Firefox :: Preferences, defect)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 488706

People

(Reporter: rockmfr, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090428 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090428 Shiretoko/3.5b5pre

In Firefox 3.0, the default for privacy.item.cookies is false. In Firefox 3.5, the default is true. This causes unexpected cookie loss when "Always clear my private data when I close Firefox" is checked and "Ask me before clearing private data" is unchecked.

Reproducible: Always

Steps to Reproduce:
1. Create a new profile and start Firefox 3.0.10
2. Check "Always clear my private data when I close Firefox"
3. Uncheck "Ask me before clearing private data"
4. Visit a few websites to get some cookies
5. Close Firefox
6. Open Shiretoko 3.5pre5
7. Close Shiretoko
8. Open Shiretoko

Actual Results:  
Cookies are removed without warning.

Expected Results:  
Cookies should not be removed. One possible solution would be to always ask before clearing data on the first shutdown after upgrading.
This was caused by the checkin for bug 480169.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488706
You need to log in before you can comment on or make changes to this bug.