Translators should be warned if article title contains invalid characters

RESOLVED DUPLICATE of bug 465029

Status

support.mozilla.org
Knowledge Base Software
--
enhancement
RESOLVED DUPLICATE of bug 465029
9 years ago
9 years ago

People

(Reporter: Underpass, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; it; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: 

The page

https://support.mozilla.com/en-us/kb/Best+Practices+for+Support+Documents

states that some characters are not permitted in article titles.
But not all the translators read that page before translating articles (especially new ones) and it's easy to forget this information.

If some characters are not allowed in titles, translators should be warned about that *before* the translation is saved for the first time (or the article is renamed).

I notice that, for example, if a page title contains the "?", the article gives 
404 error. See

https://support-stage.mozilla.org/en-US/kb/test%20symbol%20in%20title

In this article

https://support.mozilla.com/en-us/kb/Firefox+has+just+updated+tab+shows+each+time+you+start+Firefox

the Indonesian translation (in staging area) has two ' in the title (and I even suppose this breaks the language selector - which in fact doesn't work).

Reproducible: Always

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465029
You need to log in before you can comment on or make changes to this bug.