QuickSearch "+" operator adds $qsword over and over for @subWords

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Query/Bug List
--
minor
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

({regression})

Bugzilla 3.2
regression
Bug Flags:
approval +
approval3.4 +
approval3.2 +

Details

Attachments

(1 attachment)

v1
741 bytes, patch
Frédéric Buclin
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
From QuickSearch.pm:

     if ($firstChar eq '+') {
         foreach (@subWords) {
             addChart('short_desc', 'substring', $qsword, $negate);
         }
         return 1;
     }

That doesn't look right--why add $qsword over and over?
(Assignee)

Comment 1

9 years ago
Created attachment 374965 [details] [diff] [review]
v1

This looks like the fix to me.
Assignee: query-and-buglist → mkanat
Status: NEW → ASSIGNED
Attachment #374965 - Flags: review?(LpSolit)

Comment 2

9 years ago
Regression due to bug 70907, i.e. since 2.22. The code in the original JS file
seems correct.
Depends on: 70907
Keywords: regression

Comment 3

9 years ago
Comment on attachment 374965 [details] [diff] [review]
v1

Looks good and works as expected. r=LpSolit
Attachment #374965 - Flags: review?(LpSolit) → review+

Updated

9 years ago
Flags: approval3.4+
Flags: approval3.2+
Flags: approval+
(Assignee)

Comment 4

9 years ago
tip:

Checking in Bugzilla/Search/Quicksearch.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search/Quicksearch.pm,v  <--  Quicksearch.pm
new revision: 1.23; previous revision: 1.22
done

3.4:

Checking in Bugzilla/Search/Quicksearch.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search/Quicksearch.pm,v  <--  Quicksearch.pm
new revision: 1.22.2.1; previous revision: 1.22
done

3.2:

Checking in Bugzilla/Search/Quicksearch.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search/Quicksearch.pm,v  <--  Quicksearch.pm
new revision: 1.20.2.3; previous revision: 1.20.2.2
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.