All users were logged out of Bugzilla on October 13th, 2018

WebServices bug query interface broken in 3.4

RESOLVED DUPLICATE of bug 477593

Status

()

RESOLVED DUPLICATE of bug 477593
10 years ago
10 years ago

People

(Reporter: gandalf, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
bzilla = xmlrpclib.ServerProxy("https://landfill.bugzilla.org/bugzilla-3.4-branch/xmlrpc.cgi")
print bzilla.Bug.search({'summary':'Root of dependency tree.'})

with:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 1253, in request
    return self._parse_response(h.getfile(), sock)
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 1387, in _parse_response
    p.feed(response)
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 601, in feed
    self._parser.Parse(data, 0)
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 868, in end
    return f(self, join(self._data, ""))
  File "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/xmlrpclib.py", line 903, in end_int
    self.append(int(data))
ValueError: invalid literal for int() with base 10: ''
(Reporter)

Updated

10 years ago
Summary: WebServices broken in 3.4 due to → WebServices bug query interface broken in 3.4

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477593
You need to log in before you can comment on or make changes to this bug.