Closed Bug 490699 Opened 11 years ago Closed 11 years ago

please QA the revised Videos page (for Firefox 3.5)

Categories

(www.mozilla.org :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jslater, Assigned: stephend)

References

()

Details

Attachments

(3 files)

Submitting the new & improved Videos page for your QA magic. Only major caveat is that the actual videos need to be re-encoded for Safari/Flash (should be test-able in Firefox 3.5 betas though - we have the Ogg Theora videos already).

This one isn't slated for l10n, so is a little lower priority than pages like first run, what's new, the main Firefox page & Fastest Firefox.

Thanks!
[1] I don't think "Open Video" needs to be a proper noun, does it?  (http://theora.org/, for reference).
Assignee: nobody → stephen.donner
(In reply to comment #1)
> [1] I don't think "Open Video" needs to be a proper noun, does it? 
> (http://theora.org/, for reference).
Agreed...let's lower case that. Thanks!
(In reply to comment #5)
> Created an attachment (id=375117) [details]
> Screenshot of Safari 4 public beta not displaying video

Ditto for Google Chrome 1.0.154.59.
Checking back in on this one. I know there was more dev work to be done...Steven, where do we stand?
(In reply to comment #7)
> Checking back in on this one. I know there was more dev work to be
> done...Steven, where do we stand?

This got pushed aside while we worked on the pages that require localization - we're back on this now. Will update shortly. Any updates from Alix on the video encoding front?
(In reply to comment #8)
> This got pushed aside while we worked on the pages that require localization -
> we're back on this now. Will update shortly. Any updates from Alix on the video
> encoding front?

Alix, any updates here?
I'm working with Rainer on this. I'll update the bug as soon as we have an ETA for the new files.
Also, we need to update:

"Firefox 3" -> "Firefox 3.5" everywhere on this page.
Comments #1, #2, & #3.

The opera issue from comment #4 appears to be a bug with Opera not handling the latest <video> tag spec.

The video playing issues in Safari and Chrome (comments #5 & #6) are pending newly encoded videos, coming soon.
Oh, I wasn't sure about the "Firefox 3" references in the video descriptions as they actually do describe videos that are at least partially about Firefox 3 (and not 3.5). Please advise.
(In reply to comment #13)
> Oh, I wasn't sure about the "Firefox 3" references in the video descriptions as
> they actually do describe videos that are at least partially about Firefox 3
> (and not 3.5). Please advise.
Good catch, thanks Steven. The thing to do here is just to remove the version number so we're just talking about Firefox, not Firefox 3 or 3.5 (the exceptions being the two videos we're in the process of creating...the 3.5 overview, and the "What's New in Firefox 3.5" video).
(In reply to comment #14)
> Good catch, thanks Steven. The thing to do here is just to remove the version
> number so we're just talking about Firefox, not Firefox 3 or 3.5 (the
> exceptions being the two videos we're in the process of creating...the 3.5
> overview, and the "What's New in Firefox 3.5" video).

Done in r25643.
Ok, the video files are now in place and should be ready for QA. Note that the main introduction to Firefox 3 video will be replaced with a 3.5 version soon.
Steven, I'm still seeing the broken Safari 4 public beta behavior I mentioned in comment 5 (sometimes I just don't get a box, and other times I get a black box, but there are no video controls and it never seems to play on its own).
(In reply to comment #17)
> Steven, I'm still seeing the broken Safari 4 public beta behavior I mentioned
> in comment 5 (sometimes I just don't get a box, and other times I get a black
> box, but there are no video controls and it never seems to play on its own).

Stephen, from the screenshot, it looks like Safari for Windows. It appears that Apple is happy to have Safari for Windows have a completely broken <video> tag with no video codecs. Should work in Safari/Mac though.
re: comment 18: Steven, indeed; it works fine in Safari 3.2.3 and 4 public beta, on Mac OS X 10.5.
Whiteboard: [waiting on evangelism / marketing to upload final videos]
I think we're good here -- the four of us (John, Krupa, Raymond, I) tested this today.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [waiting on evangelism / marketing to upload final videos]
verified fixed on https://www-trunk.stage.mozilla.com/en-US/firefox/video/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.