Windows fonts (not web content) are too big since using Ubuntu 9.04

RESOLVED DUPLICATE of bug 458612

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 458612
9 years ago
9 years ago

People

(Reporter: Nicolas, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

First, note that this problem also happend with Thunderbird 3.0b and Firefox 3.1b3

The problem is that, since I upgraded to Ubuntu 9.04, the title bar, menus, alerts, status bar, prefs, form buttons labels, and all that is not web content controled by a site have too big fonts.

Here are two screenshots taken from Firefox 3.0 - Ubuntu Firefox official package installed - where font size is ok and from Firefox 3.1b3- installed from mozilla beta release binaries -(exactly same screenshot for 3.5b4, so I put only one screenshot) where font is too big. (see additionnal infos for screenshots url)

I tried renaming the .mozilla folder in my home to force creating a new profile, pthe problem is still there.



Reproducible: Always

Steps to Reproduce:
1. Use Ubuntu 9.04 upgrader from 8.10
2. Install Firefox 3.5b4 (French)
3. Lanch Firefox.
Actual Results:  
Font is too big in chrome elements (Web contents are OK). See screenshots :

Firefox 3.0 official Ubuntu package under Ubuntu Jaunty (9.04) : http://img179.imageshack.us/img179/8163/fx30jaunty.png

Firefox 3.1b3 under Ubuntu Jaunty (9.04) : http://img179.imageshack.us/img179/3434/fx31b3jaunty.png

Expected Results:  
The two Firefox version should have same font sizes.

This problem happends also with Thunderbird 3.0beta.

Comment 1

9 years ago
It could look like subpixel smoothing is either failing or not doing it right.

Look in Preferences => Appearance => Fonts, there might be enabled or disabled features there. Mess with'em :)
(Reporter)

Comment 2

9 years ago
Whatever I change in my system appearance font settings, the chrome font remains too big. Only the title bar (that's managed by the system) changes.

No other software I use have this problem (Gimp, Ooo 3.0, Filezilla, Aptana/Eclipse,...)

My system font settings are Subpixel LCD, medium, 96dpi, RVB.

Note that I also tried to lanch FX in safe mode, the problem is still there, so it's not an extension nor a profil problem.

Comment 3

9 years ago
This is an issue with Ubuntu (see bug 458612 for details).

To fix the issue you can remove the /etc/fonts/conf.d/10-hinting-slight.conf symlink. Alternatively, you could configure the hinting in ~/.fonts.conf. You will need to restart Firefox.

Let us know if that fixes your issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458612
(Reporter)

Comment 4

9 years ago
Your solution seems to fix the bug. I just renamed the link.
Thanks.

Sorry for the duplicate, first was not clearly dealing about Ubuntu...

However it should be nice that Firefox don't make us modify our system to make it work... I don't know what's the use of this symlink, but I hope that it's not usefull somewhere else...
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Comment 5

9 years ago
(In reply to comment #4)
> Your solution seems to fix the bug. I just renamed the link.
> Thanks.

Cool!

> Sorry for the duplicate, first was not clearly dealing about Ubuntu...

No problem, it's not easy to find the relevant bug with such issues.

> However it should be nice that Firefox don't make us modify our system to make
> it work... I don't know what's the use of this symlink, but I hope that it's
> not usefull somewhere else...

Agreed, hopefully no such change will be needed once the issue is fixed in Ubuntu fontconfig package.
Fontconfig includes all the files in the /etc/fonts/conf.d directory, so the symlink is used to include the hinting configuration. All other configuration files are in /etc/fonts/conf.avail, so you can always recreate the symlink if you want to restore the original configuration.
You need to log in before you can comment on or make changes to this bug.