Closed Bug 490828 Opened 13 years ago Closed 13 years ago

Ridiculously slow Firefox Shutdown

Categories

(Firefox :: Bookmarks & History, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 407981

People

(Reporter: geos651, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

When I close Firefox, the Windows Task Manager shows that the Firefox.exe process remains active for five more minutes! The memory by the used by the process gradually increases from 54 MB to 240 MB, and then gradually decreases back to 54 MB. Then the process finally ends.
Apart from ridiculously slow termination, the user cannot even shutdown Windows after closing Firefox!

Note: Google 2 Chrome Beta with the same bookmarks file terminates instantly!

Reproducible: Always

Steps to Reproduce:
1. Launch Firefox with a large bookmarks file.
2. Close Firefox


Actual Results:  
The Firefox process remains active for a VERY LONG time after the Firefox is closed!

Expected Results:  
The Firefox process is terminated immediately after the user closes Firefox.

This a very serious problem and has been present for a very long time, since Firefox 3 switched to Places.SQLITE database.
Since Google Chrome 2 Beta also uses SQLITE and works flawlessly, apparently Firefox designers do not know how to properly implement this database.
Duplicate of this bug: 490829
you will have to provide us the bookmarks file we are talking about, at least by mail, please.
dupe of bug 407981?
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407981
You need to log in before you can comment on or make changes to this bug.