firefox should NEVER use root of a partition as profile folder, otherwise may result in severe data loss

RESOLVED DUPLICATE of bug 470927

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 470927
10 years ago
9 years ago

People

(Reporter: c.levin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

Sorry I could not test it myself, but I read a report from an user.

When trying to create a profile through profile manager, when he select D partition, firefox did not automatically create a subfolder for its profile. rather, firefox used the root folder of the partition as profile folder.

Later when he remove that profile, the whole partition is wiped out.

He also mentioned that since this process does not go through recycle bin, the data loss would be then irreversible.

I spotted a similar bug report for thunderbird. https://bugzilla.mozilla.org/show_bug.cgi?id=366373

This should be fixed, if confirmed.

Reproducible: Always

Steps to Reproduce:
1. create a new profile using profile manager
2. pick a root partition, click ok
3.
Actual Results:  
firefox uses the root partition as profile folder.

Expected Results:  
fireox should avoid using root partition as profile folder, and should create subfolder instead.

when user remove the profile,, firefox should always check to make sure it does not remove the user's other files, if necessary.

Im sorry I only read the report and I can not test this, since I have only one partition and can't take the risk.

The report is in chinese http://www.firefox.net.cn/forum/viewtopic.php?t=26719
and bug 18927
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 302087
Duplicate of bug: 470927
You need to log in before you can comment on or make changes to this bug.