AppleScript error: Can't get <<class curl>> of window 1

RESOLVED DUPLICATE of bug 516502

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 516502
8 years ago
7 years ago

People

(Reporter: Hide Kay, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090501 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090429 Minefield/3.6a1pre ID:20090429030951

This AppleScript passes the current tab's URL to other web browsers.

tell application "Minefield"
	set theURL to «class curl» of window 1
end tell
tell application "Safari"
	activate
	open location theURL
end tell

When running this script from the AppleScript menu on the menu bar, the script does not work. When clicking on the script file directly, the following warning appears:
"AppleScript Error Minefield got an error. Can't get <<class curl>> of window 1"

The problem occurred only with Minefield 3.6a1pre. Shiretoko and Firefox 3.0.x work fine.

Reproducible: Always

Steps to Reproduce:
1.Display any web page with Minefield
2.Run script
3.
Actual Results:  
Nothing happens.

Expected Results:  
The script should send the URL to other browsers.

Is this script error the same as Bug #490830?
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
Depends on: 608049
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
No longer depends on: 608049
Resolution: --- → DUPLICATE
Duplicate of bug: 516502
You need to log in before you can comment on or make changes to this bug.