Closed Bug 491100 Opened 12 years ago Closed 12 years ago

Hangs for 30 seconds on launch

Categories

(Firefox :: General, defect)

3.5 Branch
x86
Windows Vista
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 501605

People

(Reporter: darknz, Unassigned)

Details

(Keywords: hang)

Attachments

(1 file)

33.61 KB, application/octet-stream
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

Every time I launch 3.5 Beta 4 the browser will hang for 30 to 40 seconds.


Reproducible: Always

Steps to Reproduce:
1. I install 3.5 Beta 4
2. Open Firefox.exe
3. Browser does not appear for 30 to 40 seconds before appearing.
Actual Results:  
Browser hangs and window does not appear for 30 to 40 seconds.

Expected Results:  
Browser window should launch immediately or within a few seconds.

This also happens on the latest nightly builds. I have uninstalled/reinstalled, deleted every trace of Firefox every being on my system, started in Safe Mode, tried opening with a different profile, removed all the extensions/plug-ins.

Opening a subsequent window has no issue at all. Using 3.1 Beta 3 or earlier also has no issue. I can have both 3.0.10 installed and 3.5 Beta 4 installed alongside each other, and the 3.0.10 build opens perfectly fine every time.

CPU will go to approx. 50 for the 30 to 40 seconds it takes to load. I have installed this Beta on other machines and have no issues.
Is this with default set of bookmarks and no history?
Version: unspecified → 3.5 Branch
(In reply to comment #1)
> Is this with default set of bookmarks and no history?

Yes. I have tried a completely fresh install with default bookmarks and no history as well as trying with an existing profile which has bookmarks/history.
When I start Firefox 3.5 on a really slow Windows XP computer with a new profile, it takes 13 seconds the first time, and every subsequent restart 3 or 4 seconds.
With my default profile however with a bunch of extensions and 6 months of history, it takes 1 minute and 10 seconds on the same computer.
Severity: critical → major
Keywords: hang
Tried with Firefox 3.5 RC1 today after uninstalling 3.0.11. Still the same problem, possibly worse than before. I have tried installing on the same computer with Windows 7 installed instead of Windows Vista (dual boot setup) and all versions of 3.5 load quickly.
I saw this on a friends XP system as well. Is there a easy way to debug what's going on during launch?
(In reply to comment #5)
> I saw this on a friends XP system as well. Is there a easy way to debug what's
> going on during launch?

I'm keen to be a part of any debugging process that can be suggested.
timeless may have an idea.
https://deloper.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

you have three choices:
1. use !analyze -v -hang w/ windbg when it's starting up
2. use adplus (it comes with windbg, you'll need the same symbols as described in the dev-mo article, but you'll also need to read some documentation)
3. use process explorer (you'll need the same symbols as described in the dev-mo article, you can ask it for a stack trace fairly easily, but again, i don't have a tutorial).

whichever you do, we'd only ever want stack traces as attachments, no pictures, just text, no binaries, just text, just stack traces, and only as attachments, not comments.
Attached file Stack Trace
I have tried to follow Timeless' instructions about providing a stack trace - if I've done something wrong, let me know and I'll try again. This is all new to me :)
Duplicate of bug 501605.
timeless, is this bug 501605?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501605
It's a real shame that this bug didn't get spotted earlier :-(
Status: RESOLVED → VERIFIED
Or more precisely nominated for blocking...
You need to log in before you can comment on or make changes to this bug.