fix miscellaneous warnings in networking modules

RESOLVED DUPLICATE of bug 745296

Status

()

Core
Networking
--
trivial
RESOLVED DUPLICATE of bug 745296
9 years ago
6 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

(Blocks: 1 bug)

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

Attachments

(1 attachment, 2 obsolete attachments)

15.45 KB, patch
Biesinger
: review-
Details | Diff | Splinter Review
Comment hidden (empty)
(Assignee)

Comment 1

9 years ago
Created attachment 375515 [details] [diff] [review]
wrong patch
Attachment #375515 - Flags: superreview?(cbiesinger)
Attachment #375515 - Flags: review?(ted.mielczarek)
Attachment #375515 - Flags: superreview?(cbiesinger) → superreview+
Comment on attachment 375515 [details] [diff] [review]
wrong patch

this patch is identical to attachment 375514 [details] [diff] [review], you probably meant to attach a different one to this bug?
(Assignee)

Comment 3

9 years ago
Created attachment 375802 [details] [diff] [review]
patch
Attachment #375515 - Attachment is obsolete: true
Attachment #375802 - Flags: superreview?(cbiesinger)
Attachment #375802 - Flags: review?(cbiesinger)
Attachment #375515 - Flags: review?(ted.mielczarek)
(Assignee)

Updated

9 years ago
Attachment #375515 - Attachment description: patch → wrong patch
Attachment #375515 - Flags: superreview+
(Assignee)

Comment 4

9 years ago
Created attachment 384278 [details] [diff] [review]
updated
Attachment #384278 - Flags: superreview?(cbiesinger)
Attachment #384278 - Flags: review?(cbiesinger)
(Assignee)

Updated

9 years ago
Attachment #375802 - Attachment is obsolete: true
Attachment #375802 - Flags: superreview?(cbiesinger)
Attachment #375802 - Flags: review?(cbiesinger)
Comment on attachment 384278 [details] [diff] [review]
updated

+++ b/modules/libjar/nsJARInputStream.cpp
+                if ((PRUint32)bytesRead != aCount) {

can you use a constructor-style cast instead? (if (PRUint32(bytesRead) ...))

+++ b/modules/libjar/nsZipArchive.cpp
+      if ((PRUint32)byteCount < (namelen + extralen + commentlen + sizeof(sig))) {

here too

+++ b/netwerk/build/nsNetModule.cpp
+#undef assert

why this?

+++ b/netwerk/streamconv/converters/mozTXTToHTMLConv.cpp
+  if (aInLength < 0 || pos >= (PRUint32) aInLength) {

constructor-style cast

+        (nsCRT::IsAsciiAlpha(lastChar = aInString[i]) ||
+         nsCRT::IsAsciiDigit(lastChar)))

I think it would be better to just use aInString[i] in both these lines and not change lastChar.

+  PRInt32 index;

why declare that up here?

+++ b/netwerk/streamconv/src/nsAppleFileDecoder.cpp
-        long count = dataCount;
+        SInt32 count = dataCount;
+        if (noErr != FSWrite(m_rfRefNum, &count, buffPtr) ||
+            (PRUint32) count != dataCount)

Does this meean that the documentation is incorrect?
http://developer.apple.com/documentation/mac/devices/Devices-33.html

+++ b/netwerk/streamconv/src/nsAppleFileDecoder.h
-#define NUM_ENTRIES 		6
+#define NUM_ENTRIES    	    6

if you're removing tabs on other lines, remove them here as well? :)
Attachment #384278 - Flags: superreview?(cbiesinger)
Attachment #384278 - Flags: review?(cbiesinger)
Attachment #384278 - Flags: review-
oh... ignore the first two comments, looks like libjar doesn't really do that style of casts

Updated

7 years ago
Whiteboard: [build_warning]

Updated

7 years ago
Blocks: 187528
We're getting rid of necko warnings in bug 745296
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745296
You need to log in before you can comment on or make changes to this bug.