Closed Bug 491214 Opened 12 years ago Closed 10 days ago

Should "View Image" open a new tab by default?

Categories

(Firefox :: Menus, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1690030

People

(Reporter: magnetfastlane, Unassigned)

References

Details

(Keywords: parity-chrome)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; lv; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; lv; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

When you have an image in a page, you have a right-click menu entry "view image".
Clicking this opens ONLY that image in the same tab.
This feature is very good and useful, but not where the image is opened (same tab).
Much better option would be that this button ("view image") opens the image in a NEW tab (as opposed to the SAME tab), because then you wouldn't lose all the stuff that has been loaded in the tab (very important if you're on dial-up or have to pay per MB).

P.S. I know that there is an extension to do this, but I think that this has to be integrated in Firefox.

Reproducible: Always

Steps to Reproduce:
1. Open a page with images
2. Right click on any image
3. Select "View Image"
Actual Results:  
Image is shown in the same tab

Expected Results:  
Image is shown in a new tab
Middle-click "View Image". It is built in.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Wow you rock! xD

I would've never thought that you could middle-click right-click menu entries.

Still, this should be by default :P
Resolution: WORKSFORME → INVALID
Perhaps this can be made more discoverable? Maybe a small arrow icon at the end of the menu entry that opens it in a new tab?
Status: RESOLVED → UNCONFIRMED
Component: Tabbed Browser → Menus
QA Contact: tabbed.browser → menus
Resolution: INVALID → ---
Summary: "View Image" opens new tab → Middle-click on "View Image" to open in new tab should be made more discoverable
Severity: normal → enhancement
Version: unspecified → Trunk
(In reply to comment #3)
> Perhaps this can be made more discoverable? Maybe a small arrow icon at the end
> of the menu entry that opens it in a new tab?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted
Summary: Middle-click on "View Image" to open in new tab should be made more discoverable → Should "View Image" open a new tab by default?
Err, I meant to respond to this comment...

(In reply to comment #3)
> Perhaps this can be made more discoverable? Maybe a small arrow icon at the end
> of the menu entry that opens it in a new tab?

That's not an option as it would be totally non-standard, IMHO.
Middle-click does not work for me in SeaMonkey 1.1.14 nor 2.0 Alpha 3.

Same or new tab, any "View Image" still fails due to Bug 185618, respects "Content-disposition: attachment" header if present and will download instead of view in browser.
Whiteboard: [parity-chrome]
i suggest the following:
1. change the string to "view image in a new tab" and implement this behavior
2. ctrl-click/middle click will open in the current tab

would this be a good first bug to take?
Thanks for catching this. I agree with the 1st suggestions above.
Viewing image should not be loaded on the current tab by default, which interrupts user's normal task flow.
So I agree with the suggestion. Change the string to "View Image in a New Tab" to indicate the exact location.

For shortcuts, one thing to keep in mind is that the people usually have the same expectation on things that are in pattern. It's easier for them to memorize. For example, on Mac, "command+click" on hyper link is to open it in a new tab; so "command+click" on image should also open it in a new tab, not in the current tab.
Duplicate of this bug: 642598
Duplicate of this bug: 717845
See Also: → 650764
For what it's worth, on Windows, holding down the Ctrl key while clicking the context menu entry "View Image" does open the image in a new tab for me. (This is also the case with "View Background Image".)
Actually, you can view an image in a new tab by doing the following:
1. Right click on the image, and immediately release button => context menu appears, and stays up even after releasing button.
2. go to "view image" in menu, and middle-click it => image appears in new tab
Duplicate of this bug: 1192240
(In reply to Alain Knaff from comment #12)
> Actually, you can view an image in a new tab by doing the following:
> 1. Right click on the image, and immediately release button => context menu
> appears, and stays up even after releasing button.
> 2. go to "view image" in menu, and middle-click it => image appears in new
> tab

Maybe bugzilla should adopt some of facebook style. I would have attached a LIKE to the above comment.

Even though I like it, please note that:

1. This method is probably only for advanced users.

2. Some websites disable middle mouse click above images.
Other browsers have "View image in new tab".
Without explicitly listing "View image in new tab" in the menu,
most users will never know there is a way to do that.
Instead they will have to sacrifice the webpage they are reading,
just to get a better look at the image (or disturb it with CTRL+++++)
and then hope the webpage will still be there intact when they hit BACK,
thus not allowing them to view the image again if they chose, without repeating the whole rigamarole,
all because there is no "View image in new tab" menu entry.
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-chrome
Whiteboard: [parity-chrome]

Loading the image in the same tab means that you can potentially lose uncached data.
There are no downsides to loading the image by default in a new tab as far as I can see.

We implemented this in bug 1690030.

Status: NEW → RESOLVED
Closed: 12 years ago10 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1690030
You need to log in before you can comment on or make changes to this bug.