Disable MOZ_ENABLE_POSTSCRIPT by default

RESOLVED DUPLICATE of bug 394413

Status

()

Core
Printing: Setup
RESOLVED DUPLICATE of bug 394413
9 years ago
8 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 375614 [details] [diff] [review]
Don't set MOZ_ENABLE_POSTSCRIPT=1

This shouldn't be needed because we use gtk-print now and shouldn't need to enumerate printers ourselves. Disabling it will allow us to remove a bunch of code that is only built under MOZ_ENABLE_POSTSCRIPT.
Attachment #375614 - Flags: review?(vladimir)

Comment 1

9 years ago
You've tested this to ensure it doesn't regress printing (especially on GTK)? One can only be sure...
I've not seen any printing regressions with GTK.
Attachment #375614 - Flags: review?(vladimir) → review?(karlt)
Comment on attachment 375614 [details] [diff] [review]
Don't set MOZ_ENABLE_POSTSCRIPT=1

There must be plenty of code that can be removed here, but I'm not sure that
just disabling MOZ_ENABLE_POSTSCRIPT is the right thing to do for GTK.
nsDeviceContextSpecG.cpp doesn't seem designed for !defined(USE_POSTSCRIPT).

I don't know what the consequences of
nsPrinterEnumeratorGTK::InitPrintSettingsFromPrinter() returning
NS_ERROR_UNEXPECTED and nsPrinterEnumeratorGTK::GetDefaultPrinterName
returning NS_ERROR_GFX_PRINTER_NO_PRINTER_AVAILABLE would be.

It might be easier to grasp the extent of the effect if all the code using
these methods can be removed.
Attachment #375614 - Flags: review?(karlt)
This seems like a duplicate of bug 394413 (but I'm going to let someone with a greater stake in this code make the call).  As I said there, I suspect the printer enumeration logic could be completely wiped out in favor of letting gtk-print do it for us, but I don't know how to do that.

In bug 571989, whose goal is subdirectory pruning in gfx/,  I am taking the less-risky approach of dumping the contents of gfx/src/psshared into widget/src/gtk2 and stripping the #ifdefs (so the code in nsDeviceContextSpecG.cpp that is currently #ifdef USE_POSTSCRIPT becomes unconditionally defined).
OS: Mac OS X → Linux
I don't know who knows what is going on with this code.
Zach, you may know more than anyone else.
I think you're right about the dupe anyway.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394413
You need to log in before you can comment on or make changes to this bug.