16 bit cairo/gfx image surface support

RESOLVED DUPLICATE of bug 545632

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 545632
9 years ago
8 years ago

People

(Reporter: romaxa, Unassigned)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

9 years ago
I think it would be nice to try mozilla with 16bpp image rendering...
It should help to reduce image size in memory and probably improve rendering speed.

Also it should help to avoid additional data copying and color conversions which is using some CPU time in critical operations (flash video rendering in windowless plugins).
(Reporter)

Comment 1

9 years ago
Created attachment 375672 [details] [diff] [review]
Patch for cairo 1.8.6, adding 16bpp image surface format
(Reporter)

Comment 2

9 years ago
Created attachment 375673 [details] [diff] [review]
16bpp image rendering support for mozilla. full patch
Attachment #375673 - Flags: review?(vladimir)
(Reporter)

Comment 3

9 years ago
I'm not sure how to switch image decoders to 16 bit format... probably I need some help.
(Reporter)

Comment 4

9 years ago
Probably to make decoders rendering into 16bpp we should create 16bit version for 
GFX_BLOCK_RGB_TO_FRGB
GFX_PACKED_PIXEL
And fix
nsJPEGDecoder::OutputScanlines
row_callback png decoder
ConvertColormap - gif encoder
nsXBMDecoder::ProcessData
(Reporter)

Comment 5

9 years ago
Created attachment 375706 [details] [diff] [review]
Added support for nsThebesImage
Attachment #375673 - Attachment is obsolete: true
Attachment #375706 - Flags: review?(vladimir)
Attachment #375673 - Flags: review?(vladimir)
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545632
Attachment #375706 - Flags: review?(vladimir)
You need to log in before you can comment on or make changes to this bug.