Firefox hangs for a few minutes on java applets

RESOLVED DUPLICATE of bug 501173

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 501173
9 years ago
9 years ago

People

(Reporter: m, Unassigned)

Tracking

({hang})

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc10 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.0.10) Gecko/2009042708 Fedora/3.0.10-1.fc10 Firefox/3.0.10

whenever I want to do anything on the web what includes java applets, I feel a trouble coming. In 8 out 10 cases firefox will hang indefinitely while trying to load a java applet. sometimes it eventually loads a java applet and lets me use it, but in most cases I am using firefox within virtual machine, because it just works.

Reproducible: Always

Steps to Reproduce:
1. Open new firefox window
2. go to facebook.com, create a new album
3. try to add some pictures (via java applet)
Actual Results:  
firefox hangs for 2-3 minutes or indefinitely, firefox uses around 50% cpu while java_vm uses less than 5%

Expected Results:  
firefox loads a plugin within a few seconds without hangs or crashes.

I've got a Windows XP Virtual Machine where I have latest firefox and java installed - in this environment bulk image upload applet loads within 2-3 seconds, so I guess something is wrong with Firefox for linux.

I've mention facebook as an example, but it actually applies to all java applets - ie. at work I need to develop a site which has java applet - so I have to use firefox in wirtual machine as native linux firefox is not usable at all.
(Reporter)

Comment 1

9 years ago
Created attachment 375986 [details]
8 of 10 times I see this when I want to load any java applet
(Reporter)

Comment 2

9 years ago
Created attachment 375987 [details]
CPU usage while loading a java applet
Why do you guess that something is wrong with Firefox on linux and not with Java on Linux ?
You missed to include the used Java version.
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> Why do you guess that something is wrong with Firefox on linux and not with
> Java on Linux ?

sometimes after a few minutes Firefox asks whether to stop or allow to continue some chrome/Ns*.js script - which is a part of Firefox - that was easy to get with Minefield, but at the moment (latest version from trunk) crashes when I am trying to open a webpage with java applet:

[marek@d620 firefox]$ ./firefox --no-remote -ProfileManager
INTERNAL ERROR on Browser End: Could not get the JVM manager
System error?:: Resource temporarily unavailable
./run-mozilla.sh: line 131:  4478 Segmentation fault      "$prog" ${1+"$@"}

> You missed to include the used Java version.

[marek@d620 Desktop]$ java -version
java version "1.6.0_11"
Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
Java HotSpot(TM) Server VM (build 11.0-b16, mixed mode)
[marek@d620 Desktop]$
>INTERNAL ERROR on Browser End: Could not get the JVM manager


This is an error message from the java plugin itself. I guess that the plugin can not find (?) the JVM. This can happen if you copy the plugin instead of symlinking it.

>ometimes after a few minutes Firefox asks whether to stop or allow to continue
>some chrome/Ns*.js script

You should be able to copy the error message from the dialog. It would be nice to get the full error message.

Comment 6

9 years ago
Needed response to comment 5. Closing as incomplete. If you can still produce this bug after symlinking the java plugin please comment and the bug can be reopened.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 7

9 years ago
(In reply to comment #6)
> Needed response to comment 5. Closing as incomplete. If you can still produce
> this bug after symlinking the java plugin please comment and the bug can be
> reopened.

Unfortunatelly I am unable to get this message again, but problem is still not solved. Just fired up a Firefox 3.5 beta 4 (shipped with fedora 11), latest Java Sun plugin installed (1.6.0.13) and ... still the same problem - see attached image, how my browser looks like when I try to upload images.

I must say, that that does not happen on all websites - sometimes I visit chateria.interia.pl web-chat written in Java and this one has never made browser frozen, see: http://czateria.interia.pl/czat,room,126,Pub

the difference is working one uses “old” java, the Facebook one uses fancy gnome widgets which look nice (when I am lucky enough to get java working), but in most cases they make my browser crash.
Resolution: INCOMPLETE → FIXED
(Reporter)

Comment 8

9 years ago
Created attachment 382870 [details]
just tested, on facebook.com

of course CPU went up to 50% (one core was busy, the other one not), firefox caused that heavy usage, while java_vm stayed calm (<2%).
(Reporter)

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 9

9 years ago
As I wrote already - I cannot reproduce the error message - but Java still doesn't work on facebook.com for me. Sometimes when I am lucky enough after 2-3 mintues, it suddenly calms and works like nothing happened, but if I come back to the page with a java, it will hung again and this time I have to kill browser, as it won't unlock.

is there any way I could see, which part of firefox gets busy while I am getting this hungs? I am happy to help, but I don't know how to help. At the moment any time I want to add photos to facebook, I need to fire up VirtualBox and do it from Windows.
(Reporter)

Comment 10

9 years ago
Created attachment 384472 [details]
Browser error when loading java plugin

finally I've managed to re-create the javascript error, I've spotted it by accident on flightview.com website, I have visited that website before a few times and today is a first time when I got this message - usually firefox freezes for a few minutes and is not responding or responds after a few minutes.

1. typed http://www.flightview.com/TravelTools/default.asp
2. selected flight BA 95
3. clicked 'Lunch live', then 'Go live' in popup window
4. after two minutes got this error
5. after clicking 'Continue' after around 10-15 seconds firefox become responsible again.
Does this happenw ith Firefox 3.5 final or later in a new Firefox profile and Java 6 update 14
Severity: critical → major
Keywords: hang
(Reporter)

Comment 12

9 years ago
I must say, just found why java is not loading correctly - I am using just three extensions - fire bug, web developer and adblock plus - the last one is causing java to behave abnormally. when I disable adblock, I can see nice “java loading” animation and plugin just works.

Though I need adblock to block all this flashy stuff which I don't need as it slows down firefox a lot and drives me crazy... :(

closing as not-a-bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 501173
You need to log in before you can comment on or make changes to this bug.