url not displayed for tabs until network timeout after session restore on different network

RESOLVED DUPLICATE of bug 339678

Status

()

Firefox
Session Restore
--
minor
RESOLVED DUPLICATE of bug 339678
9 years ago
9 years ago

People

(Reporter: Jesse McNelis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

When I close firefox and move to or from a network with a proxy server, upon restoring firefox attempts to reload all my tabs with the previous proxy settings, all the tabs fail to display the url of the page until after the network timeout and if stopped from loading they fail to diplay the url at all.

Reproducible: Always

Steps to Reproduce:
1. set firefox to use a proxy server
2. open a bunch of tabs
3. close firefox
4. move to a networks that doesn't have access to the proxy server
5. re-open firefox and restore session
6. stop a tab from loading before the network timeout
7. observe the blank url bar for that tab
Actual Results:  
url bar is blank for that tab

Expected Results:  
url bar contained url even if page load has been stopped.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339678
You need to log in before you can comment on or make changes to this bug.