bad absolute link for 'login' when server has two IP addresses and urlbase is set to one of them

RESOLVED DUPLICATE of bug 329638

Status

()

RESOLVED DUPLICATE of bug 329638
10 years ago
10 years ago

People

(Reporter: yubao.liu, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: 3.2.3

In my bugzilla 3.2.3 installation, the host machine has two IP
addresses, one for intranet, one for internet, the 'urlbase'
is set for intranet, this makes users from internet can't
login bugzilla successfully, because the 'login' link in footer bar
and form action in index.cgi have absolute urls that only fit for
intranet users.

This problem affects old versions too like 3.0.4.


Reproducible: Always

Steps to Reproduce:
1. setup server to have an intranet IP and an internet IP
2. set urlbase to http://INTRANET-IP/.....
3. login from Internet
Actual Results:  
The browser can't load result page because it points to an intranet resource.

Expected Results:  
The users from intranet and internet all can login successfully.
(Reporter)

Comment 1

10 years ago
Created attachment 376203 [details] [diff] [review]
a little rude patch to solve this problem

This isn't a perfect patch, just a workaround. It's better to
consider the url of current page and adjust the absolute url
for 'login' in footer bar and form action in index.cgi.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.2.3

Comment 2

10 years ago
Comment on attachment 376203 [details] [diff] [review]
a little rude patch to solve this problem

This is not what we want. Redirection to sslbase is intentional depending on parameters.
Attachment #376203 - Flags: review-

Comment 3

10 years ago
This is covered by bug 329638
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 329638
You need to log in before you can comment on or make changes to this bug.