TM: ecma/Expressions/11.4.8.js - incorrect computation

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
10 years ago
3 years ago

People

(Reporter: bc, Assigned: jorendorff)

Tracking

({regression, testcase})

1.9.1 Branch
x86
Mac OS X
regression, testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
http://test.bclary.com/tests/mozilla.org/js/js-test-driver-standards.html?test=ecma%2FExpressions%2F11.4.8.js;language=type;text/javascript;jit

~1024 reason: wrong value
~1048576 reason: wrong value
~1073741824 reason: wrong value
~128 reason: wrong value
~131072 reason: wrong value
~134217728 reason: wrong value
~16384 reason: wrong value
~16777216 reason: wrong value
~2048 reason: wrong value
~2097152 reason: wrong value
~256 reason: wrong value
~262144 reason: wrong value
~268435456 reason: wrong value
~32 reason: wrong value
~32768 reason: wrong value
~33554432 reason: wrong value
~4096 reason: wrong value
~4194304 reason: wrong value
~512 reason: wrong value
~524288 reason: wrong value
~536870912 reason: wrong value
~64 reason: wrong value
~65536 reason: wrong value
~67108864 reason: wrong value
~8192 reason: wrong value
~8388608 reason: wrong value


ecma/Expressions/11.4.8.js browser only, jit only

caused by http://hg.mozilla.org/tracemonkey/rev/b8cf788763a0
bug 487134
Flags: wanted1.9.1?
Flags: in-testsuite+
(Assignee)

Updated

10 years ago
Assignee: general → jorendorff
(Assignee)

Comment 1

10 years ago
bclary, I can't reproduce this.  Is it still happening for you?
(Reporter)

Comment 2

10 years ago
no, it hasn't failed since 2009-05-08. -> wfm thanks.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
Flags: wanted1.9.1?
You need to log in before you can comment on or make changes to this bug.